2

I've been trying to reconfigure vmware to recognize a datastore as SSD strorage. I've found several articles regarding this:

VmwareKB, Virtually Ghetto, Storage Monk. However i'm running into issues:

When I run:

esxcli storage nmp satp rule add --satp SATP --device naa.6842b2b02599aa00181935940bbfce4c --option "enable_ssd"

I get the error:

Error: Invalid option enable_ssd

If I run

esxcli storage nmp satp rule add --satp SATP --device naa.6842b2b02599aa00181935940bbfce4c --option "enable_ssd"

I get the error:

Plugin 'SATP' is not a registered SATP. Please select a plugin from the list in
'esxcli storage core plugin registration list -N SATP' or use the --force option
 to force the use of this SATP.

I attempted to use the --force command and can see the rule if I run

~ # esxcli storage nmp satp rule list | grep enable_ssd
SATP                 naa.6842b2b02599aa00181935940bbfce4c                                                  enable_ssd                  user   

However the datastore is still coming up as non-ssd. Any ideas or easier ways to accomplish this ? Thanks


Edit Output of esxcli storage nmp device list

naa.6842b2b02599aa00181935940bbfce4c
   Device Display Name: Local DELL Disk (naa.6842b2b02599aa00181935940bbfce4c)
   Storage Array Type: VMW_SATP_LOCAL
   Storage Array Type Device Config: SATP VMW_SATP_LOCAL does not support device configuration.
   Path Selection Policy: VMW_PSP_FIXED
   Path Selection Policy Device Config: {preferred=vmhba1:C2:T0:L0;current=vmhba1:C2:T0:L0}
   Path Selection Policy Device Custom Config:
   Working Paths: vmhba1:C2:T0:L0
   Is Local SAS Device: false
   Is Boot USB Device: false
~ # naa.6842b2b02599aa00181935940bbfce4c
  • 2
    In the examples 'SATP' is just a variable that is to be replaced by the real SATP value (e.g. VMW_SATP_CX), and this is displayed by "esxcli storage nmp device list". What is the output of this command on your host? – VFrontDe Oct 4 '13 at 11:37
  • @VFrontDe See Edit – bumble_bee_tuna Oct 8 '13 at 12:03
2

Since this is probably a small local installation, did you follow the last step in the VMware KB article?

You must reboot the ESXi host to tag the local datastore (if ESXi is installed locally) as the SSD drive.

| improve this answer | |
1

You are meant to replace SATP with the SATP of the device as displayed in the Storage Array Type field - in this case VMW_SATP_LOCAL. The directions aren't the clearest.

The following should work for you: esxcli storage nmp satp rule add --satp VMW_SATP_LOCAL --device naa.6842b2b02599aa00181935940bbfce4c --option=enable_ssd

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.