UPDATE: I rebuilt the entire system with the retail release of Server 2012 R2 instead of the preview, I also more closely followed the Test Lab guide, but I am still having the same issue.

I built a test lab using the Windows Server 2012 R2 Preview. The initial test lab has the following configuration (I have replaced our name with "OurCompanyName" because I would like it if Google searches for our name did not cause people to come to this site, please do the same in any responses)

Physical hardware running Windows Server 2012 R2 Preview full GUI, acting as Hyper-V host (joined to the test domain as testVwHost.testVw.OurCompanyName.com) with the following VM's running on it

  • VM running 2012 R2 Core acting as domain controller for the forest testVw.OurCompanyName.com (testDC.testVw.OurCompanyName.com)
  • VM running 2012 R2 Core with nothing running on it joined to the test domain as testIIS.testVw.OurCompanyName.com
  • A clean install of Windows 7, all that was done to it was all windows updates where loaded and sysprep /generalize /oobe /shutdown /mode:vm was run on it
  • A clean install of Windows 8, all that was done to it was all windows updates where loaded and sysprep /generalize /oobe /shutdown /mode:vm was run on it

I then ran "Add Roles and Features" from testVwHost and chose the "Remote Desktop Services Installation", "Standard Deployment", "Virtual machine-based desktop deployment". I choose testIIS for the roles "RD Connection Broker" and "RD Web Access" and testVwHost as "RD Virtualization Host"

The Install of the roles went fine, I then went to Remote Desktop Services in server manager and wet to setup Deployment Properties. I set the certificate for all 3 roles to our certificate signed by a CA for *.OurCompanyName.com.

I then created a new Virtual Desktop Collection for Windows 7 and Windows 8 and both where created without issue. On the Windows 7 pool I added RemoteApp to launch WordPad, For windows 8 I did not add any RemoteApp programs.

Everything now appears to be fine from a setup perspective however if I go to https://testIIS.testVw.OurCompanyName.com/RDWeb and log in as the use Administrator (or any orher user) I don't see the virtual desktops I created nor the RemoteApp publishing of WordPad.

I tried adding a licensing server, using testDC as the server but that made no difference.

What step did I miss in setting this up that is causing this not to show up on RDWeb?

If any additional information is needed pleas let me know. I have tried every possible thing I can think of and I am just groping around in the dark now.

The virtual machines running on testVwHost
enter image description here

The configuration screen for RD Services
enter image description here

The Windows 7 Pool
enter image description here

The Windows 8 Pool enter image description here

This is logged in as testVw\Administrator
enter image description here


Probably a long shot but are the users you are testing with part of the Domain Users group? You currently have it set so only "TestVw\Domain Users" will be able to access apps/desktops.

Only situation I've seen come close to what you are seeing is when a user not part of one of the allowed groups logs in through the RDWeb website. They will authenticate with the AD and get past the initial login page but will see a blank "Work Resources" page as you are showing.

| improve this answer | |
  • Unfortunately I did test that, I tested with several standard user accounts that was a member of the Domain Users group. I also tried with the domain administrator account (that is the one i took the final sereenshot with) – Scott Chamberlain Oct 18 '13 at 2:25

I wiped and rebuilt the system again for a 3rd time, however this time it worked fine. One thing I did different was I put the connection broker on TestVwHost instead of it's own server or on vwIIS like in the first test.

I don't know if that makes the difference, but it is now working.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.