5

So i've setup NTP on my linux CentOS server but my server time is still off by 1 hour. Currently it is 3:53am EST however, on my linux machine it shows "2:53 AM EST" this is with NTP and using ntpdate time.nist.gov and couple other servers trying to sync my server's time but all of this still have my server 1 hour behind the EST time.

Anyone know how to possibly fix this?

  • What does ntptrace show on the server? Running ntpdate is not the same as using NTP. – MadHatter Oct 6 '13 at 8:08
  • I obviously have it started up and running. In any case simply running ntptrace doesn't show work since the server doesn't recognize the command. – user1952811 Oct 6 '13 at 8:17
  • 2
    Daylight savings time? – Mark Henderson Oct 6 '13 at 8:19
4

Make sure that you have an up to date tzdata package. If you rely on correct time display, then this is a critical package you should keep up to date, as it holds all of the worldwide rules for daylight saving time.

Make sure you set the desired timezone in /etc/sysconfig/clock in addition to setting up /etc/localtime.

Make sure you aren't accidentally using the US/East-Indiana zone, which does not observe daylight saving time.

3

EST is UTC -5. EDT is UTC -4.

So, when you say Currently it is 3:53am EST you mean Currently it is 3:53am Eastern, which is currently EDT.

How exactly did you configure your server's time zone settings? It's correct in reporting a difference of 5 hours from UTC in EST. However, since we're currently in daylight savings, so you probably want your server running EDT (and switching between EST and EDT as appropriate).

  • I didn't actually configure the timezone settings. But yes, I need it to switch between EST / EDT so it is always synced, any idea how I can do that? – user1952811 Oct 6 '13 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.