I'm trying to set up a CentOS installation on my ESXi host using VMware VSphere client, and despite my efforts, I continually receive an error. After creating the VM and attempting to start it for the first time, the startup bar fails at 20% and throws an error which states only "Insufficient resources" and checking the event log, the error is noted as a "General System Error." I have worked through several online troubleshooting guides, the most relevant seeming to be (http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1006232), however to no avail. Any help or tips would be greatly appreciated.

  • How much free disk soace ram etc do you have? Also details of the host would be appreciated. – Zapto Oct 7 '13 at 20:08
  • Yeah, not enough information. – ewwhite Oct 7 '13 at 20:16
  • The host has 16 GB of memory installed, 400 MB of which is not allocated to the guest. The disk has 28 GB free, all of which is allocated to the virtual disk. The host is an HP Proliant DL380 with 2 quad core Xeon 5450 CPUs. I'm not sure what else is relevant, so please inquire as necessary. – deftfyodor Oct 7 '13 at 20:32
  • In case it is relevant, I face the same error when I reduce VM memory to 1 GB and the virtual disk to 10GB, so I am not inclined to blame those features. – deftfyodor Oct 7 '13 at 20:37

Hope this one will give you a hint

"It happens because a VM is given a reservation that is larger than the free resources currently available"

here's the link

[book][1] [here]http://my.safaribooksonline.com/book/operating-systems-and-server-administration/virtualization/9780071664523/resource-management/ch11lev1sec6


This one bugged me for a long time. A lot of research, a call to VMware..eventually I found something (don't remember where) and kept bugging the VMware phone support until they escalated it and got some questions answered.

I blogged about it in detail here. Hope it helps

"VMWARE cpu and ram reservations fixing insufficient resources error"


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.