Disclaimer: Using windows to share files is definitely not as simple as on *nix, even if it seems like.

First, I'm assuming we can securely (with passwords) share files / folders in basically only two ways:

  1. Have the same user+password on both machines or
  2. Authenticate on the connected shared folder. (providing user name and password)

Is this right? Well...

For some reason, neither way to share folders works properly, in this setup:


  • Windows 7 (several machines, in fact)
  • Windows 2008 Server - no domains, no Active Directory
  • cawas account set on both, with same non-blank password
  • mygroup group set on Windows 2008 Server, which contains cawas
  • several users, other than cawas set on Windows 7

Yeah, sure, "why don't you use domains?" is a valid question here. Well, I don't know as well. We don't have an admin and it seems like too much work for too little need. Anyway...


If I set cawas on the server, I can easily access it from win7, from whichever user I'm logged in.

But if I set just mygroup (and remove cawas) on the server, I can only access it if I'm logged in as cawas on win7. It doesn't even ever asks for a user name and password. Even if I enforce the authentication by using mapping it still doesn't work.

The error is either "can't connect" or "share point already using another username / password", but nothing I do can fix those messages, including net use /delete. The symptom is always the same: doesn't even allow to connect.

The strangest thing happens on another windows 7 machine... Same setup, but it asks for user name and password, we type in, it works! That one doesn't even have cawas (or any user) set as the same from the server.

So, what's going on? How can we fix this?

  • You've lost me. Why didn't you setup local accounts on your server for each user (e.g. SERVER\user1) and then let those users map drives/access the shares with their respective SERVER accounts?
    – TheCleaner
    Oct 9, 2013 at 21:58
  • @TheCleaner I did. It worked in most machines. Not on mine.
    – cregox
    Oct 9, 2013 at 22:54
  • As I said on the edit (do you mods prefer to read it there or here, as a comment?) I don't know how to make this question clearer. Did all of you who put this on hold really read this? Can you point what's shady?
    – cregox
    Oct 10, 2013 at 18:06
  • I voted to close it as unclear, and meant to comment why but forgot. IMO, your issue is not on how it was setup (your basically only two ways comment). You said yourself it worked on most machines just not yours. Therefore I don't think your issue is how to set it up (you seem to know how) but the real issue is why didn't it work on your machine vs. the others. The question could probably be reopened to be honest. I just think you need to clarify if your issue is "how do I get my machine to access the share now?" or "am I sharing out files in a nondomain enviro incorrectly?"
    – TheCleaner
    Oct 10, 2013 at 18:29
  • @TheCleaner but do you see how this issue is not just about that? There are at least 2 issues rolled into one here: (1) windows 8 groups - using groups instead of users make the current "credential vault" stop working and (2) what you said. Let's call it corrupted vault credential. And both answers that exist right now help solving my particular issue but both approaches only from (2). I bet there's also some solution to (1). But thanks, I'll edit to comply with what you said! ;-)
    – cregox
    Oct 10, 2013 at 18:34

2 Answers 2


You can add, edit, or remove credentials by going to Control Panel > User Accounts > Credential Manager. For example, if you're not being prompted for a user name and password, and you would like to be, select the saved credential and choose "Remove from vault".

If you don't see the Credential Manager in your Control Panel, an alternative way of opening it is by opening Run (Windows_Key + R) and entering control /name Microsoft.CredentialManager.

  • I have found no such "Credential Manager", do you have more pointers? As for the rest, it's nice to know "the standard method only relabels". It was what I did, actually. And it was enough. But you could've added that as a comment to my answer or even suggest an edit (though I think for this second you need more rep score). This is a Q&A and the answer gets much better if it's fully self explanatory with only dim references to the question or other answers, although it's much more reasonable to follow up the question at least.
    – cregox
    Oct 10, 2013 at 16:56
  • 1
    If you don't see the Credential Manager in your Control Panel, an alternative way of opening it is by opening Run (Windows_Key+R) and entering "control /name Microsoft.CredentialManager" (without quotes).
    – Jason
    Oct 10, 2013 at 17:41
  • Also, renaming it on Local User and Groups as advised really mess things up. I did it and I had to undo it. Thank god I had a secondary admin account as common preventive measure for windows. It's much better keep with the "just relabeling".
    – cregox
    Oct 10, 2013 at 17:59
  • Running control /name Microsoft.CredentialManager worked great to open that panel! It is under Control Panel > User Accounts and Family Safety > Credential Manager. I'm just not sure this works yet... Doing some tests... ;-)
    – cregox
    Oct 10, 2013 at 18:19

In fact, there's one very practical solution to this: use the same user on windows 7 from the server! It's easy to rename the user on win 7, if that's the problem. This is how we solved my issue - although it doesn't address the stated problem.

There seems to be, indeed, some kind of user name and password "cache" Windows do. Probably, if you delete that user from the buggy win 7 machine and recreate it, the problem will be gone. I just can't bother to research more and searching for more info on this yielded to no results.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.