1

I am beginner in debian system. I have run into problem - on my VirtualBox Debian system I have installed mysql and apache2 (two simple commands, what could go wrong), but after installing apache, the default web page on 192.168.0.100 leads to not found status. I have no permissions to access error.log file. Could somebody advise what is the problem? Thanks in advance for your help.

1

Are you trying to access it from inside the same machine or from a different machine?

If you're getting that error when you try to access the page from the same system, you should make sure Apache is running:

/etc/init.d/apache2 restart

If you're getting that error when you try to access the page from a different machine, either another VM or the host system or another system entirely, you should make sure it isn't being blocked by the firewall:

/etc/init.d/iptables stop

If you can access the web page from a different machine with the firewall stopped, you'll need to add a rule to allow http traffic through, usually on port 80.

UPDATED AFTER CHAT:

Issue ended up being the wrong IP was being used to reach the VM and the Apache2 instance. User determined this himself during investigation.

| improve this answer | |
  • I have Debian in Oracle VirtualBox and I want to access it from my browser in my own system (same PC). I have tried restarting, even reinstalling apache, but the default web page on that address does not show. – Tom11 Oct 10 '13 at 18:24
  • Did you check the firewall? What is the status of apache2? /etc/init.d/apach2 status. Also, FYI, so far as the VM knows, your computer is a different system than it. Can you ping the VM from your PC? The issue could be you don't have the network setup properly for Virtualbox. – music2myear Oct 10 '13 at 18:47
  • Status: Apache2 is running. After turning off Windows Firewall the web page has not load. How could I find out if I have network setup properly? – Tom11 Oct 10 '13 at 18:49
  • Did you turn off the firewall on the VM? NOT the PC. The VM has its own firewall that needs to be managed. – music2myear Oct 10 '13 at 18:51
  • Also, in the VM settings, what is the network adapter attached to? It should be set to Bridged Adapter. (Virtual Box, Right click on VM select Settings, Network, Attached to:) – music2myear Oct 10 '13 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.