0

I have a Debian server (which is a AWS EC2 Instance) and I have multiple AWS volumes attached to the server, which are all mounted in /mnt. However if I ever reboot the server (which happens whenever I create an AMI image), when it reboots all the drives are no longer mounted. I can easily remount them but I am a little concerned that it may get rebooted by someone else in the future so I was wondering if there was a way to automate the mounting.

4
  • Note: I'm aware of the no-reboot option when making AMIs, but that's not the point ;)
    – ingh.am
    Commented Oct 14, 2013 at 19:13
  • Is this a virtual server?
    – Colyn1337
    Commented Oct 14, 2013 at 19:46
  • Ah yes, sorry AWS = Amazon Web Services. So yea! Does it make a difference though?
    – ingh.am
    Commented Oct 14, 2013 at 22:27
  • @Downvoter, care to share a reason?
    – ingh.am
    Commented Feb 2, 2015 at 21:15

2 Answers 2

4

This is configured in /etc/fstab using the auto option.

1
  • 2
    auto is included in defaults.
    – 84104
    Commented Oct 14, 2013 at 21:38
4

Check out the /etc/fstab file. man fstab for more information about setting it up.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .