We've recently migrated to Office 365 with a new Active Directory structure and as part of this the naming convention for all the e-mail addresses has changed. This isn't a problem for most users, but some users have stationery with their old style e-mail address so we need to add these address as aliases for these users.

Because we use DirSync, we can't edit the mailboxes directly in Office 365. I found some instructions online which said to add the additional addresses to the ProxyAddresses field in Active Directory. I've done this, but now the address I've added to ProxyAddresses is showing up as the primary SMTP address in O365.

How can I add an alias without this alias becoming the primary SMTP address?


I didn't realise that this was case sensitive, so I've updated all the users that I changed with "smtp" lower case. Now the primary SMTP address is the user@domain.onmicrosoft.com address, which I also do not want.

Can't upload a screenshot presently due to being at work, but here is what it would show:

In Office 365:





Entries in bold are primary addresses. The primary SMTP address should be user@mydomain.com.

In Active Directory, the ProxyAddresses field contains the following data:


For a user that does not have an alias (the ProxyAddresses field is empty), Office 365 shows the following:





Inside ADSIedit under the ProxyAddresses field is correct.

You want the primary one to be preceded by SMTP: in all caps. In this case set it as SMTP:user@domain.com

The secondary/tertiary ones should be preceded by smtp: all lowercase. In this case set it as smtp:useralias@domain.com

Make sure the mail attribute in their user account in AD (the one on the General tab that says "E-mail") has the user@domain.com email address as well.

After a dirsync it should show an additional proxy address synced over as the "onmicrosoft.com" one but with lowercase smtp:

Also note, that if your domain hasn't been "verified" in Office 365 then it will revert back to using the onmicrosoft.com address.

Let me know if that works for you.

| improve this answer | |
  • thanks for that, I didn't realise this was case sensitive. I've update these, but now the primary SMTP address is the user@domain.onmicrosoft.com address which is not what I want. – toryan Oct 15 '13 at 14:32
  • can you post a screenshot of adsiedit? You should be able to simply edit the proxyaddresses to be something like "SMTP:user@domain.com" "smtp:useralias@domain.com" "smtp:user@domain.onmicrosoft.com". – TheCleaner Oct 15 '13 at 14:35
  • updated my answer – TheCleaner Oct 15 '13 at 16:16
  • are you saying that, essentially, it is necessary to include the primary SMTP address in the ProxyAddresses field as well as additional addresses if that field is not left blank? – toryan Oct 15 '13 at 18:28
  • 1
    I believe that is true, yes. If it is blank the account will queue off the mail attribute. See here for more info too: derekgoh.wordpress.com/2012/02/14/… – TheCleaner Oct 15 '13 at 18:55

@TheCleaner proposed one solution.

The other way that you can do this is opening Active Directory Users and Computers. Click the View option and then click advanced features. Your AD forest should reload. Find the user that you want to add the secondary SMTP address in and then go to the properties of that user. In all the tabs you will see an option that says attribute editor, this has all of the properties of ADSI edit in the user's properties. You will then follow the directions that @TheCleaner posted.

Please note that the Attribute editor will not show up when you search for a user in Active Directory Users and Computers.

Again @TheCleaners answer is correct, this is just a shortcut to get to ADSI Edit to make it more convenient for your day to day workflow.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.