0

I am having weird issues with my website, everyone except me is able to reach my website but whenever I try to login to my website I am getting a Server Not Found issue. The website has never had this kind of weird issue. I contacted my hosting provider; there is nothing from his side, the server is up, domain is pointing to the right nameservers. After a lot of research I understood that the problem might be DNS cache and tried to flush DNS in my Mac Terminal and it suddenly worked fine for few weeks and now again I am unable to access my website from my own computer. While trying to connect to it using proxies it is again working fine but I am unable to connect directly using my computer's browser. I tried flushing DNS again and again but this time it's no use. Ping shows unknown host but my third party server uptime monitors still say the server never goes down. Any idea what would be the cause for this?

Domain name is www.creativeproperty.com.au

3
  • How new is the domain name registration?
    – Colyn1337
    Oct 15, 2013 at 17:21
  • 1
    Your web site and DNS are fine; you need to check your computer and your ISP. Oct 15, 2013 at 17:22
  • It's pretty old, around 4 years I guess and never had this kind of issues before, recently changed hosting provider I believe issues started after that.
    – Root
    Oct 15, 2013 at 17:23

1 Answer 1

1

Run "nslookup your-domain.com" in your terminal; does this reveal the correct IP?

If nslookup does not show the right IP:

  1. Click Apple -> System Preferences -> Network -> (Select the network connection you're using on the left) -> [Advanced...] -> [DNS]
  2. Remove each of the DNS servers listed in nslookup by highlighting them and clicking [-].
  3. Now click [+] and add the following DNS servers (one per line): 8.8.8.8, 4.2.2.2, 8.8.4.4
  4. Click apply and exit the network preferences.
  5. Run "dscacheutil -flushcache" in the terminal.
  6. Disconnect and reconnect to the network to make sure the settings were applied.

If those were your ISPs DNS servers you may want to contact them if it's been over 72 hours and ask why those changes haven't propagated.

Make sure to ping the DNS servers I suggested and make sure the latency is acceptable, if not find a good set of local DNS servers using namebench (https://code.google.com/p/namebench/).

If nslookup does show the right IP:

Make sure you didn't make any entries in /etc/hosts. If you did you will need to "sudo su" in your Mac's Terminal in order to write to the file and make changes.

Completely close and reopen the browser you're having trouble with.

3
  • You are genius mate. Just small issues, nsloopup in terminal says it is pointing to router i.p. i.e. my domain currently pointing to 192.168.1.254 and 192.168.1.254#53 and at the same this router i.p. is present in DNS server list also but I am unable to remove it from there, it's just greyed out in Mac osX.
    – Root
    Oct 15, 2013 at 17:36
  • You are super genius. It worked!! Thanks a ton mate.
    – Root
    Oct 15, 2013 at 17:42
  • No problem :) Glad it worked for you.
    – Jeff
    Oct 15, 2013 at 17:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .