I have a win 2008 domain server name \ADDC I can ping, open etc. there are some printer installed on it, and I would like to deploy to some domain users.

after I deploy successfully, in their "printer and devices" shows printer like "Xerox on \\ADDC\xerox7556" It says offline, and whatever I send to print nothing happens. but if I add the printer manually (open the ip \, then right click on the printer and connect) there will be a new device name "xerox on \\\xerox7556" everything work. I tried to ping addc, and it respond with the ip

any idea how to fix? be cause I dont want to manually add printer..

Edited: I have 2 DC one with dns server also, the other one is just replication: Edited2: sorry to cause confusion, I had the ip wrong, now I fixed the question so nslookup outputs:

Server:  UnKnown

Name:    addc.domain.com
Address:    <---where printer server
  • 1
    What's the output of nslookup ADDC from one of the clients? – Nathan C Oct 15 '13 at 18:02
  • I added the output due to better formatting – Yichaoz Oct 15 '13 at 20:38
  • Wait a second here. Is a domain controller for the same domain as Or is it something else? – MDMarra Oct 15 '13 at 21:40
  • yes it is. it's just for failover purpose, and it's a replication – Yichaoz Oct 15 '13 at 21:53
  • What does "it's a replication" mean? Do you mean that it is another DC in the same domain? – MDMarra Oct 15 '13 at 22:05

1 - First for printer deployment via GPO, make sure you've installed the printer correctly on the server (including drivers for 32 and 64 bit clients if needed), deployed the printer with a per user GPO, for the right users. This video sums up pretty well a simple configuration: http://www.youtube.com/watch?v=4kJbnJ4xHrA

2 - Then the GPO should be deployed at logon, or just execute gpupdate /force on the client.

3 - If you don't get any success on the client after Steps 1 and 2, make sure you can at least print from the server, that may be the root problem...

To me the problem has nothing to do with names, dns server, or wins server, as you can access the printer from the client.

  • I tried to print with server and no problem. print on the client with \\ADDC\xerox7556 = fail \\\xerox7556 works – Yichaoz Oct 15 '13 at 20:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.