0

I trying to set alternate IP for gain access to MySQL Server (accessing from a PC with IP 192.168.1.20) in the file: my.ini

MySQL starts without problem, when in the configuration file, in the section mysqld I have:

[mysqld]
...
bind-address=0.0.0.0

But, does not starts when in the configuration file, in the section mysqld I have:

[mysqld]
...
bind-address=192.168.1.20 #Remote IP of Client PC

Showing the error code 1067:

With bind-address=0.0.0.0, all remote IP's are enable to gain access to my MySQL Server, I want to restrict only to 192.168.1.20.

How Can I fix this, or what is my mistake?

BR.

1 Answer 1

3

You can't bind to a remote IP address because bind assigns the local address to a socket, which must either be a local address or a wildcard. I'm not sure what you're trying to do, but whatever it is, that's not the way to do it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.