I have a CentOS websver with a Samba share set up (\\webserver\websites).

I was connected to this share just yesterday without issue, but today my Windows 8 PC will not connect to it. I've also tried making a connection from Windows 7 and Windows XP, all without success.

I initially tried restarting my computer, but that did not work. I then tried restarting the Samba service on the webserver (service smb restart), and when that failed I restarted the webserver.

All of that was to no avail, and I still cannot connect to the share.

The webserver is contactable from my PC (and the others I tried), as the websites it hosts work fine and I'm able to Putty to the server.

When connected to the webserver, I can see that Samba is running by using service smb status -

service smb status
smbd (pid 4685) is running...
nmbd (pid 4688) is running...

Can anyone please help me to get this share working?

Here is my full Samba config (/etc/samba/smb.conf) -

        workgroup = MYGROUP

        server string = Samba Server %v

        log file = /var/log/samba/log.%m

        max log size = 50

        security = user
        encrypt passwords = yes

        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        local master = no

        comment = Websites
        browseable = yes
        writable = yes
        valid users = dgard

Success. This was a firewall problem. I'm not sure what caused it, but the firewall stopped allowing connections via port 445.

I checked on a backup of the server from a few nights ago and sure enough, an entry for port 445 from a certain IP range did exist in /etc/sysconfig/iptables. I restored that single file, and all is right with this very small part of the world.

I have no idea how or why that entry disappeared, but if I ever find out I will update this answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.