Today I noticed my website http://mint-nachhilfe.ch/ was down, but other people (located in different networks) said it looks up from there. When I came home, I double-checked, and I can really reach it from here. Also, this website considers it down.

Some facts:

  • It's a Tomcat webapp, connected to an Apache2 server. I restarted both, no change.
  • Another (ruby on rails) application is connected to this Apache2, which I couldn't reach either, but is considered online by above check website.
  • At any point, I could directly connect to the Tomcat over http://mint-nachhilfe.ch:8080!

I don't know how to go on searching for the root error. I assume it's related to the Apache2 server, but how could that be?


It is reachable directly by the IP I got from an nslookup triggered inside the problematic network. The problem seems to be related to Apache's domain distinction. My VirutualHost entry looks as follows (there are few others as well):

<VirtualHost *:80>
    ServerName www.mint-nachhilfe.ch
    ServerAlias mint-nachhilfe.ch *.mint-nachhilfe.ch

    JkMount /* worker1

Is there anything wrong here?

  • 1
    ping.ms/#mint-nachhilfe.ch says the server is reachable from just about everywhere. Must be Apache if you're still seeing issues. Anything in Apache's error logs about denied requests or whatever? – Chris S Oct 17 '13 at 15:21
  • 1
    What does your apache httpd.conf file say? Are there any deny from's in there? – Travis Stoll Oct 17 '13 at 15:34
  • My httpd.conf is empty. The error log says a lot of things I don't completely understand (I'm no server expert). In the time when I tried to access it, there's only one entry: server reached MaxClients setting, consider raising the MaxClients setting. Not sure what this means exactly. Also, the problem persisted after a restart. – Cedric Reichenbach Oct 17 '13 at 17:51
  • Wouldn't the error you're getting suggest that you edit the Tomcat configuration and change the MaxClients setting? What OS are you running your Apache/Tomcat on? – Deesbek Oct 17 '13 at 18:32
  • @ChrisS: I could always successfully ping the server, even ssh worked flawlessly. – Cedric Reichenbach Oct 18 '13 at 16:38

Look for and edit the MaxClients in your Tomcat configuration.

Restart your Tomcat server.

  • There were 3 entries of MaxClients. I increased them from 40 to 80. Nothing changed. – Cedric Reichenbach Oct 18 '13 at 16:41
  • @CedricReichenbach Did you restart both Tomcat and Apache after the change? I am sure you did but just thought I would ask. – Deesbek Oct 18 '13 at 17:19
  • Had restarted Apache, and now did the same for Tomcat, just to be sure. Nothing changed. – Cedric Reichenbach Oct 18 '13 at 18:03
  • Maybe DNS issues. Can you access it internally via IP? If you can then it is a DNS issue. – Deesbek Oct 18 '13 at 18:06
  • Yes, I can (just updated my question). But I can also reach it through domain:8080, which is directly served by Tomcat. Also, nslookup returns the correct IP. – Cedric Reichenbach Oct 18 '13 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.