0

In IIS 7.5 on Windows webserver 2008 I get a 500 response on any request. Checking in firebug if I'm being forwarded but the request is made and no forwarding, just get 500 response with a page that looks like Symfony response page.

Disabled all url re writes and requested index.html (still get 500) checked error pages under featured settings and detailed errors is checked. Checked the php error log and no writes have been made for several days.

[UPDATE]

While I was writing this and listing things I've tried I tried selecting detailed error messages at the root node, not the site node. Looks like someone changed file permissions so that IIS can no longer read the config file.

1

When selecting detailed error messages at the root node (not the site node) I get some information:

the related configuration data for the page is invalid. ... This error occurs when there is a problem reading the configuration file for the Web server

Looks like someone changed file permissions so that IIS can no longer read the config file.

Gave full permission to NETWORK SERVICE and the error went away. (Actually after adding both NETWORK SERVIcE and IUSR it still gave me the error so just added everyone with full permission. Sometimes the best way to remove a splinter is using a sledge hammer.)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.