14

Running Apache2 on Ubuntu Precise64 in Vagrant. When I try to start it, it says:

vagrant@precise64:/etc/apache2$ /etc/init.d/apache2 start
 * Starting web server apache2
 *
 * The apache2 configtest failed.
Output of config test was:
AH00534: apache2: Configuration error: No MPM loaded.
Action 'configtest' failed.
The Apache error log may have more information.

But the thing is, my /etc/apache2/apache2.conf file doesn't call for MPM anywhere! I would paste it here but it would make for a huge post...

I tried looking up the error log, but I can't find that anywhere, either. Help?

Edit: apache2 -l gives this:

vagrant@precise64:/$ apache2 -l  
Compiled in modules:             
  core.c                         
  mod_so.c                       
  mod_watchdog.c                 
  http_core.c                    
  mod_log_config.c               
  mod_logio.c                    
  mod_version.c                  
  mod_unixd.c                    
  mod_unixd.c                    

So it looks like no mpm is installed, right? If no MPM installed and no MPM mentioned in my config file, why am I still seeing this error?

1
  • 1
    What is the output of dpkg -l 'apache2-mpm*'
    – sciurus
    Commented Oct 19, 2013 at 18:02

2 Answers 2

11

apache2 -t -D DUMP_MODULES (or -M) should give you a list of modules. You should see worker.c or prefork.c or event.c. Use this to determine which MPM you're using.

Look in your config files if there's something like (if you use the prefork MPM).

Here's an example :

<IfModule mpm_prefork_module>
StartServers          5
MinSpareServers       5
MaxSpareServers      10
MaxClients          150
MaxRequestsPerChild   0
</IfModule>

Add a block like this one to your config file and it should work. Verify that the apache2-mpm-prefork (or worker, or event) is correctly installed.

Read this documentation to help you choose (it is mandatory) the appropriate MPM for your usage : http://httpd.apache.org/docs/2.2/mpm.html

5
  • Updated the original question with the command output... It looks like there is no mpm model at all, so I don't understand why I am seeing the error. Any idea?
    – ezuk
    Commented Oct 18, 2013 at 12:21
  • 1
    You must choose a MPM module, it's mandatory.
    – Vinz
    Commented Oct 18, 2013 at 22:12
  • Hi @Vinz. I actually have the same problem (Ubuntu 13.10, Apache 2.4.6) and tried your solution. I was missing that block in my config file, but adding it did not solve the problem. Any other ideas? I'm kinda lost here. Commented Oct 25, 2013 at 8:10
  • @ItaiBar-Haim : What is the error message after adding this block ?
    – Vinz
    Commented Oct 28, 2013 at 10:11
  • @Vinz it was the same error. However I found out that when I use the default Apache configuration and not trying to override it in any way things seem to work. Commented Oct 29, 2013 at 6:26
14

I had the same issue. I accidentally overwrote /etc/apache2/apache2.conf. To rectify, I had to run sudo apt-get purge apache2 to completely remove apache and then run sudo apt-get install apache2 to get the original apache2.conf file back.

NOTE: Back up any custom files under /etc/apache2/sites-available before purging.

2
  • I had a similar problem with running Vagrant and it turns out I had accidentally erased all the content in apache2.conf. A bit easier to revert though vagrant destroy && vagrant up.
    – forsvunnet
    Commented Jan 15, 2016 at 12:43
  • sudo apt-get purge apache2 worked some kind of magic. Thanks for this. I forget about purge sometimes.
    – b_dubb
    Commented Oct 20, 2023 at 18:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .