The problem

I have been trying to install SQL Server 2012 on Windows Server 2012. I continually get the same error:

Managed SQL Server Installer has stopped working

Problem signature:
  Problem Event Name:   CLR20r3
  Problem Signature 01: scenarioengine.exe
  Problem Signature 02: 11.0.3000.0
  Problem Signature 03: 5081b97a
  Problem Signature 04: Microsoft.SqlServer.Chainer.Setup
  Problem Signature 05: 11.0.3000.0
  Problem Signature 06: 5081b97a
  Problem Signature 07: 18
  Problem Signature 08: 0
  Problem Signature 09: System.IO.FileLoadException
  OS Version:   6.2.9200.
  Locale ID:    1033
  Additional Information 1: c319
  Additional Information 2: c3196e5863e32e0baf269d62f56cbc70
  Additional Information 3: 422d
  Additional Information 4: 422d950c58f4efd1ef1d8394fee5d263

What I've tried

After initial googling, I've tried the following things:

  • Go through the list of hardware and software pre-reqs. All the software seems to be there by default on Server 2012 and my hardware meets the reqs.
  • Copy the installation media to the local drive and try to install from that (rather than a DVD). This produced the same error.
  • Based on another error message, I installed .NET 4.0 (which apparently is not on Server 2012 out of the box). Same error.
  • Install from command line. This didn't work either, but it gave me a different error:


Unhandled Exception: System.IO.FileLoadException: Could not load file or assembl
y 'Microsoft.SqlServer.Configuration.Sco, Version=, Culture=neutral, Pub
licKeyToken=89845dcd8080cc91' or one of its dependencies. Strong name validation
 failed. (Exception from HRESULT: 0x8013141A) ---> System.Security.SecurityExcep
tion: Strong name validation failed. (Exception from HRESULT: 0x8013141A)
   --- End of inner exception stack trace ---
   at Microsoft.SqlServer.Chainer.Infrastructure.InputSettingService.CheckForBoo
leanInputSettingExistenceFromCommandLine(ServiceContainer context, String settin
   at Microsoft.SqlServer.Chainer.Setup.Setup.DebugBreak(ServiceContainer contex
   at Microsoft.SqlServer.Chainer.Setup.Setup.Main()

The application log has this:

Event id 1026

Application: ScenarioEngine.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.FileLoadException
   at Microsoft.SqlServer.Chainer.Infrastructure.InputSettingService.CheckForBooleanInputSettingExistenceFromCommandLine(Microsoft.SqlServer.Chainer.Infrastructure.ServiceContainer, System.String)
   at Microsoft.SqlServer.Chainer.Setup.Setup.DebugBreak(Microsoft.SqlServer.Chainer.Infrastructure.ServiceContainer)
   at Microsoft.SqlServer.Chainer.Setup.Setup.Main()

Event id 1000:

Faulting application name: ScenarioEngine.exe, version: 11.0.3000.0, time stamp: 0x5081b97a
Faulting module name: KERNELBASE.dll, version: 6.2.9200.16384, time stamp: 0x5010ab2d
Exception code: 0xe0434352
Fault offset: 0x00000000000189cc
Faulting process id: 0x8fc
Faulting application start time: 0x01cecc205109f96e
Faulting application path: D:\x64\ScenarioEngine.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: 9174db4d-3813-11e3-93f1-000c29908169
Faulting package full name: 
Faulting package-relative application ID: 

Any ideas what I am missing?

2 Answers 2


I figured it out--portions of the install need .NET 3.5 which is not standard on Server 2012. To enable this on Server 2012, you need to put the 2012 disk in, and type the following command in the shell prompt:

dism /online /enable-feature /featurename:NetFX3 /all /Source:d:\sources\sxs /LimitAccess

Found the solution here. Also, reviewed the pre-reqs again at Microsoft's KB2681562.

  • This did not 100% solve my issue, but it made it so the wizard is popping up now.
    – Jeff
    Commented Oct 21, 2013 at 19:20

Got almost the same error. Was not able to get the SQL installation wizard going, just a error: "managed sql server installer has stopped working" + CLR20r3 + filenotfoundexception. Tried on other Win2012r2 installations, new vanilla install and new install with updates with no success. Solution: Removed windows updates kb2966826-27-28 and then it worked. Link: https://support.microsoft.com/en-us/help/3002547/you-cannot-enable-the-microsoft--net-framework-3-5-feature-on-windows My god - this was not awesome.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .