1

I installed Apache through its windows installer and then PHP and MySQL too. Wordpress is working fine on this setup so it means the basic setup required is working fine.

But somehow mod_rewriting is not working even though i have uncommented the LoadModule.....mod_rewrite from httpd.conf.

whenever i go to some permalink on my localhost I just get a 404 (browser based, not wordpress based).

Please suggest the required changes that i need to do.

3
  • 4
    Did you restart apache?
    – Greg
    Aug 16 '09 at 12:29
  • Did you have a look in your error_log?
    – innaM
    Aug 16 '09 at 12:42
  • @greg yes i did. but radius solved the problem
    – OrangeRind
    Aug 16 '09 at 13:45
3

My guess is that your AllowOverride directive doesn't allow the .htaccess file of wordpress to be used. So double check that AllowOverride FileInfo is enable for your wordpress directory.


For the future when you ask these sorts of questions please include :

  • any rewrite configuration you've done in apache
  • the content of the .htaccess file in the root directory of wordpress
  • apache version
1
  • 1.I haven't done any rewrite config, i just enabled permalinks through wordpress. 2.contents are what wordpress makes them by default, 3.apache 2.2.13 there you go!
    – OrangeRind
    Aug 16 '09 at 13:30
1

Most likely your wordpress .htaccess file isn't being used by apache. Inside your httpd.conf file replace "Override None" with "Override All".

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.