I had my personal site at freehostia and now i have shifted to some other server. It has been close to a week, and ofcourse as the NameServers changed for the new host, i made the required changes with domain-register-company, for my domain.

Now when i try open to my site, at times it open the new hosted-site, at times it open the 404 page on the old site.

I think 1 week, say even 4 days is a lot of time for DNS propagation to happen. Is this a strange behaviour.

When i open the site from the IP address it opens, but when i open the site with a domain-name, at times it open, and at times it doesnot. Any clue?

I tried with two of my friends, who have never visited my site, so no dns cache on his machine, it opened for one, and didnot open for the other. thanks

-- From http://Squish.net
25.0% of queries will be returned by (dns1.freehostia.com) vks.uni.cc. 3600 IN A
25.0% of queries will be returned by (dns2.freehostia.com) vks.uni.cc. 3600 IN A
25.0% of queries will be returned by (ns1.softuff.com) vks.uni.cc. 14400 IN A
25.0% of queries will be returned by (ns2.softuff.com) vks.uni.cc. 14400 IN A

I donot understand what is this 25%, why is it not 100% or 50%
dns1.freehostia.com and dns2.freehostia.com were old servers. ns1.softuff.com and ns2.softuff.com are new servers.

6 Answers 6


My answer to this question has a run-down of propagation time that I'll link to instead of copying+pasting here.

More specifically from your question it sounds to me like you authoritative name servers have not been updated (or are listed wrong so the wrong ones are being queried). To see what name server records your local DNS servers thing are being used for the domain you can use the dig <domain.tld> NS like so:

$ dig spillett.net NS
spillett.net.           316     IN      NS      ns1.nogoodnamesareleft.com.
spillett.net.           316     IN      NS      ns2.nogoodnamesareleft.com.

you can then check them to see if they all have the right address for the name:

$ dig @ns1.nogoodnamesareleft.com www.spillett.net
www.spillett.net.       349     IN      CNAME   spillett.net.
spillett.net.           349     IN      A
spillett.net.           349     IN      NS      ns2.nogoodnamesareleft.com.
spillett.net.           349     IN      NS      ns1.nogoodnamesareleft.com.
ns1.nogoodnamesareleft.com. 3499 IN     A
ns2.nogoodnamesareleft.com. 3499 IN     A

(repeat the above for each NS record returned by your first query)

The TTL values returned by the queries directly against your domain's nameservers should always be the actual value set in the zone record (they are low in the example above as that domain was moved around recently and I forgot to set them back up higher when I'd finished), where-as for queries against non-authoritative servers (i.e. one of your default local name servers, which will be queried if dig is not given an @<server> directive) will be how long before that server next checks (against the nameservers listed as NS records for the domain) if its cached version needs to be updated.

Checking the above tests for your domain may give you some more clues as to where the source of the issue lies. If you are using Linux and don't have dig, it is usually found in a package called something like dnsutils (it is called that on Debian ad Ubuntu, I assume a similar arrangement on other distributions) - there are no doubt many ports to Windows (this is the first relevant looking page returned by Google) though I've never used any of them myself.


It sounds like the DNS server YOU are using is caching the old result.

How long a DNS record is cached typically depends on the TTL (time to live) but not every DNS server respects that.

One more (maybe obvious) thing... if you are using your OLD DNS server for lookups... make sure you've deleted the old zone. :-)

If it worked for your two friends but not for you I'd recommend changing the DNS servers your computer is using for lookups... even if temporary.

I'd recommend changing your computer's DNS lookup servers to something like OpenDNS... just to test and see.


If none of that works... let us know what domain name you're having the issue with and I'm sure someone here will look into it for you and tell you if its propagated or not.

Hope this helps.


depends on dns ttl record. one week sounds quite long. try checking what are answers for dns queries from all responsible servers - visit for instance http://www.squish.net/dnscheck/ , type your domain name, select type: ANY and run the check.

maybe one of involved servers still returns old records.


One weekis more than enough time for any propagation to happen. I had similar issue and problem was that primary and secondary server weren't syncronised. I used nslookup to check current status. While my problem was with MX records, you may want to check it.


The only time it should take more than the TTL to update would be if you're changing records with your registrar. Usually, a registrar will update records once or twice every 24 hours. Normally, however, these records are the ones that point your domain to your DNS servers.

If you are updating normal (A, PTR, CNAME, etc...) records on your DNS servers, and they're running bind, you should be able to do an "rndc reload domain.name" (or "rndc reload domain.name IN view") to schedule an immediate update.

One last caveat, browsers maintain their own cache, as well as the OS's DNS client. I've been frustrated more than once by an apparent lack of update when all I really needed to do was "ipconfig /flushdns" on the Windows client.


DNS changes are pretty much instant; what I think you're asking for is how long it takes to propagate if you make changes at the registrar?

If you change your nameservers at the registrar you can incur between 6-48 hours of downtime while changes propagate across the world.

If you simply add or modify records to your DNS management console the changes are pretty much instant.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .