0

I build Apache httpd into an RPM using these sites:

I was successful at building apr* and httpd*. However, when I try to install httpd using

rpm -Uvh httpd-devel-2.2.25-1.x86_64.rpm httpd-2.2.25-1.x86_64.rpm mod_ssl-2.2.25-1.x86_64.rpm

I get the following error:

package mod_ssl-2.2.3-82.el5_9.x86_64 (which is newer than mod_ssl-2.2.25-1.x86_64) is already installed.

I have httpd 2.2.3-82 installed. Do I need to remove it first? Seems counterintuitive.

1

The first link points to a guide for installing the current stable apache version - 2.4. The second link refers to apache version 2.2. These are not arbitrarily interchangeable; for starters, they are markedly different in both internals and configuration.

But most importantly, each apache version and package needs to be built with the same version of apr/apxs in order to be able to use modules. This is documented profusely in the apache httpd installation instructions.

I strongly suggest building and installing the latest stable apache version (at the time of writing, 2.4.6) as it has been GA for over a year.

And, as is obvious from your post, remove the old version of apache and mod_ssl before installing this one.

  • Ok, I didn't know there were so many different changes. Will try 2.4.6. – Brian Oct 22 '13 at 21:05
  • 2
    BE SURE to carefully read the changelog for 2.2 -> 2.4; your 2.x configuration will most likely not work without some alteration. – adaptr Oct 22 '13 at 21:08
  • Got it. I now understand this won't be an easy task. I will read carefully. – Brian Oct 22 '13 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.