We were able to setup mysql master-slave replication with the following version on both master/slave:

mysqld Ver 5.5.28-29.1-log for Linux on x86_64 (Percona Server (GPL), Release 29.1)

One day, we noticed that replication has stopped, we tried skipping over the entries that caused the replication errors. The errors persisted so we decided to skip replication for the 4 problematic tables. The slave has now caught up with the master except for the 4 tables.

What is the best way to enable replication again for the 4 tables?

This is what I have in mind but I don't know if it will work:

1) Modify slave config to enable replication again for the 4 tables

2) stop slave replication

3) for each of the 4 tables, use pt-table-sync --execute --verbose --print --sync-to-master h=localhost,D=mydb,t=mytable

4) restart slave database to reload replication configuration

5) start slave replication


In my opinion, the cleanest way to do this would be

  1. Dump the 4 tables from master and restore these dumps to the slave tables
  2. modify your slave config to enable the replication for these tables again
  3. restart slave database

This way you can be sure the 4 tables on master and slave are the same.

What you have in mind should probably also work, at least if you trust the percona toolkit :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.