1

This is on a fresh computer (super computer actually). It got to me with 15T on the home mount and 50G on the root. I tried allocating 7T to root and resizing (since I'm putting a local yum repo on this machine as it has no internet access nor will it ever).

I tried following the instructions here: Centos 6.3 disk space allocation but something went wrong and the home won't mount again. Instead I get from dmesg | tail:

EXT4-fs (dm-2): bad geometry: block count 4294967295 exceeds size of device (1342177280 blocks)

df -h nets this output:

Filesystem                                  Size    Used   Avail Use%    Mounted on
/dev/mapper/VolGroup-lv_root   7.0T  3.6G  6.6T   1%          /
tmpfs                                         190G  216K  190G   1%        /dev/shm
/dev/sda1                                485M   38M   422M  9%    /boot

I didn't have any files on /dev/mapper/VolGroup-lv_home. Will simply running mke2fs fix it to be mountable? What sort of options should I run it with. I've never resized volumes before or used mke2fs. I don't want to make this mess worse.

0

It could possibly caused by some trickery of a drive controller possibly in an enclosure - and the problem will likely disappear if reinserted back the way it was - or configured back to the settings as it was when the filesystem was originally created - or it could just be a firmware or utility off-by-one bug (used to be fairly common) - but

sudo resize2fs /dev/mapper/Vol_home

Will fix the superblock (and truncate any data that might have been in the last blocks - which presumably has now been claimed by your controller and won't be made available to the system with the current configuration anyways).

0

So after some researching I gave up and decided to reformat it.

mke2fs -t ext4 /dev/mapper/Vol_home

Good thing I didn't have any data on there to begin with.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.