I have an Ec2 instance that i created on Amazon aws server with 8G of volume, later i found out i needed to increase the size of the server, then i found this answer using EBS attached volume using EBS instead of S3

then i created a new volume of 800G and attached it to my Ec2 volume, but still yet, and it showed me a message telling me it has attached successfully.

But my volume doesn't still receive more than 8G of files. I sent a mail to AWS contact, but no response.

Please any help on this will be appreciated.

  • your server will see if in linux if you do a fdisk -l but if your root is lvm, then you need to grow the partition using that 800gig ebs – Mike Oct 25 '13 at 16:31

When you create and attach a new EBS volume, it's just as if you attached a new physical hard drive to a physical server - it's a block storage device, but you need to instruct the OS what to do with it. So, after attaching, you need to format the volume and mount it somewhere.

Assuming the new volume is /dev/xvdb:

$ mkfs.ext4 /dev/xvdb
$ mkdir /opt/mountpoint
$ mount /dev/xvdb /opt/mountpoint

At this point, that storage is available at /opt/mountpoint. You'll also need to add this new filesystem to /etc/fstab so that it gets mounted automatically on next boot.

| improve this answer | |
  • thanks for your answer, i ran the comand sudo mkfs.ext4 /dev/xvdb and sudo mkdir /opt/mountpoint as told and it worked successfully...BUT sudo mount /dev/xvdb /opt/mountpoint gives me an error that saying "ONLY ROOT CAN DO THAT". I tried Logging with username "root" instead of "ubuntu" but wasn't successful, Please what else can i do ???? – Html Tosin Oct 28 '13 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.