I am sitting on a Win XP machine trying to connect to a Windows 2008 Server.

I think the cause of this issue might be due to the fact that I said yes to install a terminal server back when I installed the server as I didn't know it wasn't nessecary for RDP. I don't know if this i9s what is blocking the connection but something is.

The error message (translated from danish):

"The remote computer disconnected the session due to an error in the licensing protocol. Try again or contact serveradministrator."

Now the real issue here is that I can't remote desktop and fix the error. I have also tried: mstsc -console without any luck.

Any suggestions are welcome :)


You can try rebooting the server, but you'll need to check on the license server to see if there are any errors.

If you installed Windows 2008 in Terminal Server mode you'll need to get on the server and remove Terminal Services in order to get the admin RDP working again. You probably don't have any Terminal Service licenses to use.


If you don't install a Terminal Licencing Server within 120(?) days of installing the Terminal Server service, Terminal Services will cease to operate. And of course, once you do install a license server, you need to install licenses!

However, this should not stop you from using the /console switch (although keep in mind, if this is vista, its been renamed to /admin) just as long as the Allow Remote Desktop Connections is ticked in the system properties.

Unfortunately because of the translation of the message I can't match it to an exact message that I'm familiar with, but it sounds a lot like an issue with expired licenses, or no licensing server.


From Technet

1.On the client, navigate to the following registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing.

2.Click MSLicensing.

3.On the Registry menu, click Export Registry File.

4.In the File name box, type mslicensingbackup, and then click Save.

5.If you need to restore this registry key in the future, double-click mslicensingbackup.reg.

6.On the Edit menu, click Delete, and then click Yes to confirm the deletion of the MSLicensing registry subkey.

7.Close Registry Editor, and then restart the computer.

When the client is restarted, the missing registry key is rebuilt.

Edit: I didnt read your question properly, as mrdenny said you dont need to install the Terminal Services role in order to remotely access the server for administration. Althogh it will work for 120 days without additional TS CALS. Uninstalling Terminal Services should fix the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.