0

0 down vote favorite

I have been running all over the web trying to find a solution to this problem. I am trying to deploy an umbraco site to a vps build is:

Windows Server 2008 R2 IIS 7.5 Umbraco CMS

app pool integrated v4.0

I have tried many different solutions. II tried to do what was listed here: IIS - this configuration section cannot be used at this path (configuration locking?)

I found that I don't have 'in the features window, Click: "Internet Information Services"'. I'm not sure if that is related or not. This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".

that is the error I am getting, error code 0x80070021. Its happening on this line . I have also tried the solution listed here:

http://forums.iis.net/t/1155232.aspx

to no avail. There shouldn't be any issues with file permissions either... I added IIS_IUSRS and IUSR with full control to see if that had any part.

Any info is appreciated.

0

Stupid mistake... but have to admit the error wasn't very descriptive.

found the answer here: http://forums.asp.net/t/1735022.aspx

"Verify framework 2.0 is registered with IIS, If it is not registered, to do this

open the command promt=> C:\Windows\Microsoft.NET\Framework64\v2.0.50727 aspnet_regiis -i"

though I installed v4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.