6

My problem is a little confusing. I have 2 servers (Windows Server 2008 R2) with MSMQ installed and I want to use Server B to consume a MessageQueue on Server A. When I try to Receive it always throws a message error: "Access to message queuing system is denied.".

IP between them.

Server A: 172.31.23.130

Server B: 172.31.23.195

FormatName:Direct=TCP:172.31.23.195\private$\queuesource (It's working for Sends)

  • I can ping each server from the other;
  • The firewall is disabled;
  • The "queuesource" has Full Control to "Everyone", "Anonymous Logon", "Network", "Network Services";
  • Journal is disabled;
  • Authentication is ok;
  • The queue is Transactional.

My code in .Net C# is basically like this:

MessageQueue _sourceQueue = new MessageQueue();
_sourceQueue.Path = "FormatName:Direct=TCP:172.31.23.195\private$\queuesource";
_sourceQueue.Receive(); // << here throw an exception.

Actually I'm using the Private Queue only to avoid Active Directory's problems. For example, if the server DNS fail all network fail. I don't know what do anymore.

  • 2
    I'm sorry, but I have to say this: Ping is not an MSMQ debugging or troubleshooting tool. The Windows firewall will not cause an "access denied" message. What in the error message led you to believe that ping was an appropriate tool to use and what led you to believe the firewall has anything to do with the problem? The first step in troubleshooting any problem is understanding the system you're troubleshooting and knowing which tools to employ to troubleshoot said problem. Google has a lot to say about this message - google.com/#q=Access+to+message+queuing+system+is+denied – joeqwerty Oct 29 '13 at 16:12
  • 3
    Thanks for answer joeqwerty, but I found the answer: In "Server Manager">"Features"> Right click in "Message Queueing">"Properties"> Tab "Server Security" and disable the option "Disable un-authenticated RPC calls". – JeanKininho Oct 29 '13 at 17:50
  • Glad you got it solved. – joeqwerty Oct 29 '13 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.