8

I'm connecting from Windows 7 Ent to Windows Server 2008 R2. I followed several guides to setup audio redirection. Playback works, but no recording.

  • "Record from this computer" checked on client
    enter image description here

  • microphone on client works

  • "Windows Audio" service on server running
    enter image description here

Now I have 2 options:

  1. uncheck 2 audio-related options in RDP-Tcp Properties enter image description here

  2. allow audio redirection in group policy. This makes the above options grey. enter image description here enter image description here

I tried both options

  • set "fDisableAudioCapture" = 0. It's already set to zero by unchecking in "RDP-Tcp Properties" dialog
    enter image description here

  • log off and log in

  • open "Recording devices" and check "Show Disabled Devices" and "Show Disconnected Devices"

No audio devices are installed

enter image description here enter image description here

1
  • Thanks for making such a thorough post. I had the same problem and your post helped me zero in on the solution below.
    – aaz
    Apr 6 '15 at 18:21
12

Go to Administrative Tools / Server Manager / Roles / Add Roles. Add the Remote Desktop Services role. In the Role Services submenu add Remote Desktop Session Host. In the Client Experience submenu select "Audio and video playback" and "Audio recording redirection".

After installing this a Remote Audio device appears in the Recording tab.

3
  • 1
    Worked for me on Server 2012 R2! I couldn't find the Client Experience submenu so I had to enable those settings via the Group Policy editor as described at technet.microsoft.com/en-us/library/dd759231.aspx though
    – Kvothe
    Sep 22 '15 at 21:27
  • 1
    Worked for me on Windows Server 2019 Datacenter! I added only the Role Services -> Remote Desktop Session Host. Jun 2 '19 at 19:52
  • 1
    Following this answer is dangerous! After adding the Remote Desktop Services role I've lost remote access to my 2012 R2 server. RDP connection failed with message "The remote session was disconnected because there are no Remote Desktop License Servers available to provide a license". The "solution" was removing the role via physical console.. Still no sound..
    – Aleksandr
    Oct 27 '20 at 11:30
3

I ran into the same issue. In order for it to work I had to change the registry setting on the Remote Desktop Client, not the host machine.

The following registry subkey can disable the Audio Recording Redirection feature:

HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

fDisableAudioCapture REG_DWORD 0 | 1

In Windows 7 Enterprise Edition, this registry subey is set to 1 by default. Therefore, Audio Recording Redirection is not available.

In this case it would not help to set the policy value to Enabled. Instead, you must set the subkey to 0.

1
  • Do you have devices on "Recording" tab on server?
    – basin
    Jul 2 '14 at 5:39
0

Follow this Kb Article:

http://support.microsoft.com/kb/2020918

Additionally ensure you can see "Remote Recording" on the TS.

1
  • 1
    What? I wrote already that fDisableAudioCapture is 0
    – basin
    Jun 4 '14 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.