Ok this is stumping me mainly because of the lack of experience I have with access control. I have two folders I need to keep away from users. Payroll and Banking.

I went into security and took away all the users. I made a new group called access granted and added it to both folders. I then gave full control to the group. I then added a few days to this group.

I tested with partial success. I can only get into some folders and subfolders/files. I made sure I clicked on the option for all subfolders.

This is my layout

C:(folder) --> permissions granted to admin,access (full control)

when I look at the problem files/folders no one has any permissions I don't even see the group or admin.

what am I doing wrong.


  • What are the permissions on one of the sub folders you can't get into? It sounds like the permissions didn't replicate fully, or that you have a deny rule at a lower level. – sgtbeano Oct 31 '13 at 15:43
  • there is no deny rule. For an example lets say I have C:\folder\2012\... files in here. The folder will have right permissions but 2012 will only have admin and not the group I added on folders.. The files will be the same.. Or.. I wont have any names listed under group/names – user160605 Oct 31 '13 at 15:51
  • I think I might be on to something. Under C: I have the followings groups/usernames admin,creater,everyone,access,system,users. To get rid of the users for C:\payroll and c:\banking I had to uncheck allow inheritable permissions. Could this be my problem? because if I click it again it adds users back to the names and groups and I dodnt want all users to have access. Should I get rid of users right off the C: and just create separate groups. Example would be Employees and another supervisors. Gives employees access to everything but those two folders. And then gives supervisors access to all – user160605 Oct 31 '13 at 16:01
  • Are you using the Advanced security settings? (technet.microsoft.com/en-us/library/cc726071.aspx) – sgtbeano Oct 31 '13 at 16:05
  • is there a easy way to do this all in AD? – user160605 Oct 31 '13 at 16:06

As you're using Advanced Security settings I'd start at your top level folder you want set permissions on, apply the correct groups / users etc. and make sure you check;

Replace all existing inheritable permissions on all descendants with inheritable permissions from this object

This may take some time depending on the depth of the folder structure and the number of files.

(more detail here -> http://technet.microsoft.com/en-us/library/cc730772.aspx)

  • Great stuff, glad it worked. – sgtbeano Nov 4 '13 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.