I joined two hyper-v servers to a domain and added shared storage to both of them. From what I read I should be able to run the test-cluster cmdlet at this point for it to check the configuration, but when I run it, it throws an access denied error. I'm running it as the default administrator account for the domain.

PS C:\Users\administrator.LAB> test-cluster -Node 'hyperv-02','hyperv-01'
test-cluster : Access is denied. (Exception from HRESULT: 0x80070005
At line:1 char:1
+ test-cluster -Node 'hyperv-02','hyperv-01'
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : PermissionDenied: (:) [Test-Cluster], ClusterCmd
    + FullyQualifiedErrorId : UnauthorizedAccess,Microsoft.FailoverClusters.Po

These are both 2012 R2 server core installations.

1 Answer 1


oops this was my own stupidity. I had the server name wrong. The "hyperv-02" server was actually named "hypver-02". After renaming the computer the command worked. I still think the error message could have been a bit clearer though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .