0

Can anyone tell me why inter vlan routing is working for all vlans except my newly created vlan 4/ I have an hp procurve 2610. Any help would be appreciated. I have basically this 1 switch with all unmanaged switches attached to the core. We have a second 2610 on port 28

Running configuration:

; J9085A Configuration Editor; Created on release #R.11.25

hostname "Core_HP"
interface 22
   speed-duplex 100-full
exit
ip routing
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-12,17-22,26-27
   ip address 192.168.4.6 255.255.255.0
   tagged 25
   no untagged 13-16,23-24,28
   exit
vlan 2
   name "WAN"
   untagged 28
   ip address 10.254.254.3 255.255.255.0
   exit
vlan 3
   name "Wireless"
   untagged 13-16,24
   ip address 192.168.7.6 255.255.255.0
   ip helper-address 192.168.4.2
   tagged 27
   exit
vlan 35
   name "guest"
   untagged 23
   tagged 24
   exit
vlan 4
   name "esxi"
   untagged 25
   ip address 10.10.1.1 255.255.248.0
   exit
ip route 192.168.5.0 255.255.255.0 10.254.254.1
ip route 192.168.6.0 255.255.255.0 10.254.254.1
ip route 0.0.0.0 0.0.0.0 192.168.4.10


show ip route


                        IP Route Entries

  Destination        Gateway         VLAN Type      Sub-Type   M
etric     Dist.
  ------------------ --------------- ---- --------- ---------- -
--------- -----
  0.0.0.0/0          192.168.4.10    1    static               1
          1
  10.10.0.0/21       esxi            4    connected            0
          0
  10.254.254.0/24    WAN             2    connected            0
          0
  127.0.0.0/8        reject               static               0
          250
  127.0.0.1/32       lo0                  connected            0
          0
  192.168.4.0/24     DEFAULT_VLAN    1    connected            0
          0
  192.168.5.0/24     10.254.254.1    2    static               1
          1
  192.168.6.0/24     10.254.254.1    2    static               1
          1
 192.168.7.0/24     Wireless        3    connected            0
          0

show ip 

 Internet (IP) Service

  IP Routing : Enabled


  Default TTL     : 64
  Arp Age         : 20

  VLAN         | IP Config  IP Address      Subnet Mask     Prox
y ARP
  ------------ + ---------- --------------- --------------- ----
-----
  DEFAULT_VLAN | Manual     192.168.4.6     255.255.255.0   No

  WAN          | Manual     10.254.254.3    255.255.255.0   No

  Wireless     | Manual     192.168.7.6     255.255.255.0   No

  esxi         | Manual     10.10.1.1       255.255.248.0   No

  guest        | Disabled
  • 1
    Welcome to Stack Overflow. Unfortunately, this question is off topic for Stack Overflow. Server Fault might be a better site for this. But you'll need to be more specific about your question if you'd like an answer (there as well). For example, what troubleshooting steps have you tried? Can you ping the switch at 10.10.1.1 using a device off port 25 configured with a static IP address? Is there a DHCP server on that subnet? How are the hosts configured? If you don't get ping replies, do you see arp entries? What exactly do you mean by "inter vlan routing" not working? – mpontillo Nov 2 '13 at 1:26
  • Mike sorry is it possible you can transfer it? Right now the arp table shows 10.10.1.1 and 10.10.1.2. I do not intend to have dhcp on this vlan. I also can ping the switch from 10.10.1.1 internally as well as on the vlan from a host. What i mean by inter vlan routing is that all vlan networks are routing between each other and work. Except for vlan 4 – user19039 Nov 2 '13 at 2:03
  • No, I can't transfer it. I don't have the appropriate privilege level. Can you post a route table from one of the machines on VLAN 4 that cannot access the other VLANs? – mpontillo Nov 2 '13 at 4:10
1

You didn't provide enough information to answer you 100%. 192.168.4.6 is the only route that knows where 10.10.1.1 is. Everything that needs to route to 10.10.1.1 needs a static route to 192.168.4.6. If 192.168.4.10 is the default gateway for the entire network, add a route on it. 10.10.0.0 255.255.248.0 192.168.4.6

| improve this answer | |
0

Did you intend for DHCP requests to be relayed from VLAN 4? I noticed you have the following in VLAN 3:

ip helper-address 192.168.4.2

Maybe you need a similar configuration for VLAN 4, and a corresponding configuration on the DHCP server.

You might take a look at this documentation I found for DHCP relay on the HP site.

You should also provide route tables (for example, the output of netstat -rn, ip -4 route) on the machine on VLAN 4 which cannot reach the other VLANs.

| improve this answer | |
  • No plan for ip helpers on vlan 4. everything is to be static'ed. – user19039 Nov 2 '13 at 2:01
  • Please don't answer off-topic questions (and you clearly knew this was off-topic, because you commented about it being so). Answering off-topic questions encourages other off-topic questions, even if the question gets closed. ("I know it's not a question for SO, but I can probably get an answer before it gets closed."). Instead, vote to close and migrate it; if you don't have sufficient privileges to do so, flag it for the moderators and ask them to do it. Thanks. – Ken White Nov 2 '13 at 4:18
  • @KenWhite, point taken. I didn't realize this was controversial; I figured if the question was migrated, it could still be helpful at the destination site. – mpontillo Nov 2 '13 at 5:11
  • This might help: Shouid I answer off-topic questions – Ken White Nov 2 '13 at 5:14
  • @KenWhite, the accepted answer says it's OK to answer questions you think will be migrated. ;-) – mpontillo Nov 2 '13 at 5:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy