1

Under System Properties / Remote, The "Allow remote connections to this computer" is enabled. Also under Service Manager / Local Server, "Remote Desktop" is enabled.

However, the "Remote Desktop Services" service listed in "services.msc" is not running and cannot be started - the start operation is disabled.

I wouldn't have thought the "Remote Desktop Services" role would be required for allowing an Administrator's RPD connection? (It was at one point installed, then removed) -- it is confusing as to the distinction between the two features.

Any ideas on how to get the RDP service operating for admin purposes?

  • What is the startup state of the service? If it's set to Disabled then set it to Enabled and start it. Both Remote Desktop for Administration and Remote Desktop Session Host use the Remote Desktop Services service. – joeqwerty Nov 4 '13 at 15:00
  • Thank you. It was set to disabled, was not aware that this stopped the service from being controlled. Now the service has started still not able to establish an RDP connection including with the firewall disabled. Might try turning it off and on again. – slat Nov 5 '13 at 3:27
1

I've been having the issue on a 2012R2 Broker Server for a few months. Everytime I patched the server and rebooted the RD Broker Server would fail to fully start. The only KB's I could find all referenced that you can't/shouldn't run the RD Broker Role on a DC. I wasn't! My only recourse was to perform a re-installation of RD Broker Role and recreate the RD Farm.

Remote Desktop Management Service fails to start with error -2010841087 and continual error messages that the broker server could not be found.

Discovered that the 'RDCmc' Database was in "Recovery Pending" mode. I simply toke the DB Offline then brought it back Online (right click DB --> Tasks -->Online/Offline). The Remote Desktop Management service was able to start and RD Collections reappeared.

0

Make sure the remote desktop client version supports network level authentication. Also make sure the user or group is listed in the Select users screen in System Properties. To eliminate routing and firewall issues you can run telnet localhost 3389 from the command prompt, and see if it connects. If so then the service is definitely answering connection requests and you can try the same from the remote computer. Edit: Replace localhost with the remote host name. Try the IP address in case DNS is the problem.

Site note: If the telnet command is not installed you can add it with the ocsetup TelnetClient command, which is case sensitive.

0

You will be able to startup the service using services.msc. You will need to first make the service enabled. For this, right click on the service which is disabled, click on properties. You may select manual instead of disabled, this way you can manually start the particular service.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.