2

I've got a VLAN 10 setup as a management VLAN.

The management VLAN comes off port 48 and links to another set of switches that do not support VLAN's so it was I believe set up as an untagged access port. In the past this was a different brand of switch and this worked fine.

However, since changing to the HP V1910-48G series I can't seem to get this working. I must point out that as far as I'm aware it is wired up properly (I can't check this physically as I'm working remote and have asked the tech who's got access to double check for me).

Now I don't have a huge amount of experience with VLAN environments but AFAIK this is right. I've set the port 48 (linked to the management switches) as an untagged port with PVID 10 and access link type.

Is this all I'd need to do from a configuration perspective to ensure all devices connected to port 48 would end up being on VLAN 10 and not needing to tag their frames. i.e. the tag would be added by the switch before being forwarded.

  • Then to me it looks like it's configured correctly. I'll have to find out what the tech says. – Matt Nov 5 '13 at 4:11
  • What do you mean it's not working? Can you be more specific about the actual problem? Are you trying to connect to the switch via the VLAN interface? Did you assign an ip address to the VLAN interface? – joeqwerty Nov 5 '13 at 5:20
  • Have your tried to see if port auto-negotiation is configured correctly on port 48? – Fergus Nov 5 '13 at 7:05
  • Are you trying to access port 48/vlan 10 from another VLAN? I agree with @joeqwerty you need to explain in detail what isn't working. You've configured port 48 to be untagged vlan 10, but your final statement about "tag would be added"...that would occur on a trunk port for cross-vlan communication/routing. – TheCleaner Nov 5 '13 at 14:19
1

It's possible that you may have accidentally configured port security to limit the number of MACs on the port to one, which is a common BCP for access ports.

Beyond this, you have certainly configured it correctly. VLAN-unaware switches should generally be connected to untagged ports. Tags will indeed be added by the VLAN-aware switch to which they are connected.

I assume not working means something like you don't get connectivity. If you can, check whether the port is up, and whether it is administratively down (not sure if your switch supports that kind of thing or not, though really most managed switches do). If it's showing that the link is down it's probably a cabling error.

Occasionally, though rarely, you can get port flapping if your cabling is bad, or if some other hardware is bad and is doing things like pretending the 10/100 interface on the other end of a connection supports 1000baseTX. Check for that too.

  • I'll check that port security thing. I don't actually see the MAC's appear on that port for any nodes connected via that port. – Matt Nov 5 '13 at 20:18
  • It may or may not be that then. Often the port security brings the port down, though. Honestly the most likely cause is at layer 1. – Falcon Momot Nov 5 '13 at 20:34
  • 1
    Mac MAC Count is set to unlimited. It must be a cabling issue. – Matt Nov 8 '13 at 0:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.