1

Exchange 2007 environment. A user on our domain tries sending an email to an external recipient and receives the following:

host mail.recipient.com[xxx.xx.xxx.xx] said: 554 5.7.1 This message has been blocked because the HELO/EHLO domain is invalid. (in reply to MAIL FROM command)> #SMTP#

This is coming from the recipient's server and I assume they are blocking us because the EHLO doesn't match the SMTP address of the user.

Basically here's our setup: We have our legacy domain name that's only used internally (name of our domain), let's call it LegacyDomain.com We have newer domain that we use as default outgoing SMTP addresses (NewDomain.com). Note that NewDomain.com is not an actual domain in our system, we just have MX records for the domain pointing to our mail server. So even though our internal domain is LegacyDomain.com when we send and receive emails we use NewDomain.com. If I'm guessing right, this message bounced back from the recipient because the Legacy and New domain don't match?

I have two Receive Connectors (not sure why) in my EMC under Server Config -> Hub Transport:

  • Client EXCHANGEHOSTNAME
  • Default EXCHANGEHOSTNAME

Both are enabled. Under Client EXCHANGEHOSTNAME my setting is blank for 'Specify the FQDN this connector will provide in responseto HELO or EHLO'.

Under Default EXCHANGEHOSTNAME my setting for the same field is the internal FQDN of my exchange server (hostname). Is this the problem?

Would I just be able to create a PTR record somewhere in these domains? I'm really confused why this is happening, and it only happens to this one recipient. We can receive emails from them just fine.

If it helps there's the debug info from the message header thats bounced back:

X-ASG-Debug-ID: 1383598536-03fb9372a0451d30001-Qq21RH
Received: from mail.LegacyDomain.com ([192.168.200.16]) by
 barracuda.LegacyDomain.com with ESMTP id JEGiO7Vbax65pvhn; Mon, 04 Nov
 2013 14:55:36 -0600 (CST)
X-Barracuda-Envelope-From: user@NewDomain.com
Received: from ExchangeServerHostName.LegacyDomain.com
 ([fe80::dc2f:93c1:195a:40d]) by ExchangeServerHostName.LegacyDomain.com
 ([fe80::dc2f:93c1:195a:40d%11]) with mapi; Mon, 4 Nov 2013 14:55:36 -0600
  • Get rid of one of the receive connectors, and set the proper HELO on the remaining one. – DanBig Nov 6 '13 at 16:59
  • Is there a way to tell which is being used? I'm pretty sure it's the DEFAULT with the send connector value filled. – drpcken Nov 6 '13 at 17:08
  • Wait wouldn't this use a Send connector instead? My send connector FQDN setting is mail.LegacyDomain.com. – drpcken Nov 12 '13 at 16:04
  • You should only need to update the Default connector's HELO to mail.NewDomain.com, you don't need to delete the Client connector. In this case the Default connector is what will respond when the remote mailserver calls back to verify. Also there seems to be a Barracuda Anti-Spam device at play, is that in front of your mail servers or the remote mail servers you are sending to? – chunkyb2002 Nov 12 '13 at 16:38
  • That's my barracuda, I dont' think it's the issue. Let me try what you said. So this has nothing to do with the send connector? – drpcken Nov 12 '13 at 16:53
2

In the Exchange Management Console, go to Organization Configuration > Hub Transport > Send Connector > Properties. Under "Specify the FQDN...", change this to the name record for NewDomain.com (e.g. mail.newdomain.com) whose DNS A record resolves to the public IP address the email server is sending from.

enter image description here

-1

Your FQDN is invalid. :(

Ensure your SSL in installed too. I've seen cause the error as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.