1

So, my server is living in the future, unfortunately I can't get lottery numbers, or stock picks out of it.

It thinks this is the time: Thu Nov 7 04:07:18 EST 2013

Not correct, I tried to set the time manually via date in a few ways

# date -s "06 NOV 2013 14:48:00"

# date 110614482013 -- same output, same problem

Which outputs Wed Nov 6 14:48:00 EST 2013, but when I check the date again, it's still set to Nov 7th 0400 or whatever.

I checked my system messages, and I see this pop up often:

Nov 7 03:54:00 www ntpd[4482]: time correction of -47927 seconds exceeds sanity limit (1000); set clock manually to the correct UTC time.

Which makes sense, we're way off the correct time. But I can't seem to manually fix it. So now what?

Also, I'm wondering if my hardware clock is setup correct, hwclock doesn't return any values. Would that be causing issues?

This is a virtualized server, I don't have direct access to the hypervisor, but I can talk to who does, assume I can explain myself well enough.

Thanks

7
  • 1
    Have you tried stopping ntpd, setting the time manually (or via ntpdate), and restarting ntpd?
    – MadHatter
    Nov 6, 2013 at 19:55
  • I think so, but I'll try it again just to be sure, thanks.
    – kevingreen
    Nov 6, 2013 at 19:56
  • Just tried setting via date, and ntpdate, unfortunately, still stuck 15 hours into the future. @MadHatter
    – kevingreen
    Nov 6, 2013 at 19:57
  • 1
    What kind of hypervisor is it? Nov 6, 2013 at 19:58
  • You did stop ntpd first, yes?
    – MadHatter
    Nov 6, 2013 at 20:01

1 Answer 1

5

At it's default settings, ntpd will refuse to make any large changes to the system clock, as it assumes something has gone wrong. To force a large NTP update, do the following:

  1. Stop the NTPD service
  2. run ntpd -gnqd
  3. Start the NTPD service again

This will cause the NTP daemon to update the time once in the foreground and will allow large time changes.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .