We're having a very weird issue at work. Our Ubuntu server has 6 drives, set up with RAID1 as follows:

/dev/md0, consisting of: /dev/sda1 /dev/sdb1

/dev/md1, consisting of: /dev/sda2 /dev/sdb2

/dev/md2, consisting of: /dev/sda3 /dev/sdb3

/dev/md3, consisting of: /dev/sdc1 /dev/sdd1

/dev/md4, consisting of: /dev/sde1 /dev/sdf1

As you can see, md0, md1 and md2 all use the same 2 drives (split into 3 partitions). I also have to note that this is done via ubuntu software raid, not hardware raid.

Today, the /md0 RAID1 array shows as degraded - it is missing the /dev/sdb1 drive. But since /dev/sdb1 is only a partition (and /dev/sdb2 and /dev/sdb3 are working fine), it's obviously not the drive that's gone AWOL, it seems the partition itself is missing.

How is that even possible? And what could we do to fix it?

My output of cat /proc/mdstat:

Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]

md1 : active raid1 sda2[0] sdb2[1]
      24006528 blocks super 1.2 [2/2] [UU]

md2 : active raid1 sda3[0] sdb3[1]
      1441268544 blocks super 1.2 [2/2] [UU]

md0 : active raid1 sda1[0]
      1464710976 blocks super 1.2 [2/1] [U_]

md3 : active raid1 sdd1[1] sdc1[0]
      2930133824 blocks super 1.2 [2/2] [UU]

md4 : active raid1 sdf2[1] sde2[0]
      2929939264 blocks super 1.2 [2/2] [UU]

unused devices: <none>

FYI: I tried the following:

mdadm /dev/md0 --add /dev/sdb1

But got this error:

mdadm: add new device failed for /dev/sdb1 as 2: Invalid argument

Output of mdadm --detail /dev/md0 is:

        Version : 1.2
  Creation Time : Sat Dec 29 17:09:45 2012
     Raid Level : raid1
     Array Size : 1464710976 (1396.86 GiB 1499.86 GB)
  Used Dev Size : 1464710976 (1396.86 GiB 1499.86 GB)
   Raid Devices : 2
  Total Devices : 1
    Persistence : Superblock is persistent

    Update Time : Thu Nov  7 15:55:07 2013
          State : clean, degraded
 Active Devices : 1
Working Devices : 1
 Failed Devices : 0
  Spare Devices : 0

           Name : lia:0  (local to host lia)
           UUID : eb302d19:ff70c7bf:401d63af:ed042d59
         Events : 26216

    Number   Major   Minor   RaidDevice State
       0       8        1        0      active sync   /dev/sda1
       1       0        0        1      removed
  • 1
    Please post output of: mdadm --examine /dev/sd[ab]1
    – Regan
    Nov 7, 2013 at 14:32

2 Answers 2


You could have bad sectors on that specific location.

Stop all the RAID arrays, then check the physical disk integrity. You could first start with a S.M.A.R.T check....



#  mdadm /dev/md0 --re-add /dev/sdb1
  • Tried that, and got the following result: "mdadm: --re-add for /dev/sdb1 to /dev/md0 is not possible"
    – reano
    Nov 7, 2013 at 14:30
  • What does 'mdadm --query /dev/sdb1' show?
    – rickhg12hs
    Nov 7, 2013 at 14:45
  • Shows: "/dev/sdb1: is not an md array"
    – reano
    Nov 7, 2013 at 14:50
  • In addition to adding output of the command requested in the comment of your original question, would you also add the output of 'fdisk -l /dev/sda' and 'fdisk -l /dev/sdb'? Is /dev/sdb SMART capable? Have you run the selftests?
    – rickhg12hs
    Nov 7, 2013 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.