8

We've setup RHEL6 on a new server. As far as we can tell, our subscription is all setup properly. However, when I run yum repolist, it doesn't show any repositories. /etc/yum.repos.d/redhat.repo is empty. I tried pasting in the content from another RHEL6 server's redhat.repo but as soon as I run yum, it wipes it out again. I just need to get the basic RedHat repositories setup so I can install packages.

To make sure I wasn't having a subscription issue. I re-registered and re-subscribed. I get all the same results.

# subscription-manager register --force
# subscription-manager subscribe --pool=*redacted*

When I log in to RedHat customer portal, it shows that subscription as active.

Using the GUI, I went to System > Administration > Red Hat Subscription Manager. Under the 'Products' tab, it did not show any products.

When I run yum update, here's what I get:

# yum update
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
This system is receiving updates from Red Hat Subscription Management.
Setting up Update Process
No Packages marked for Update

contents of /etc/yum.conf

[main]
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=3

contents of /etc/yum/pluginconf.d/rhnplugin.conf:

[main]
enabled = 0
gpgcheck = 1
  • 1
    What did you do to subscribe the machine? – Michael Hampton Nov 8 '13 at 17:56
  • I've now unregistered, re-registered, and subscribed. Yet, I get the same results. subscription-manager register --force subscription-manager subscribe --pool=redacted – eisaacson Nov 8 '13 at 18:48
  • 1
    What do your /etc/yum.conf and /etc/yum/pluginconf.d/rhnplugin.conf files look like? – tacotuesday Nov 8 '13 at 23:37
  • 2
    Call Red Hat. How did the system end up in this state? – ewwhite Nov 9 '13 at 0:51
  • 2
    The loaded plugins should include rhnplugin. Is that not installed? Is it not enabled? Is it broken in some way? – freiheit Nov 9 '13 at 0:58
7

Here's how I fixed the issue, at least temporarily. I copied the /etc/yum.repos.d/redhat.repo file from another working rhel6 server. Then I replaced all of the instances of sslclientkey and sslclientcert with the .pem files on this server. Then I renamed the .repo file to avoid it being wiped out on update. By doing that, I am able to install all packages as expected.

I'll have to continue to work with support to get the root of this problem solved.

UPDATE

Red Hat support finally got back to me with the following instructions which fixed the root of the problem and all is well:

Upon inspection of your registered systems we are showing you currently have them registered through RHSM and one of those systems is also registered through RHN classic.

Navigate to the following location after logging in through the customer portal and delete both systems by checking the boxes and clicking 'Delete Selected' on the bottom left:

https://access.redhat.com/management/consumers/

Once the above is completed locally in a terminal as root on the system 'GH-Server-5' issue the following commands:

rhn_register

The above command will open a terminal-tui for RHN Classic registration and ask for a username and password. These are your customer portal login and password. Also make sure to check all available update unless you require limited updates.

When the terminal based tui completes your registration issue the following commands to clean out yum's cache and add the correct repositories, and then finally update:

yum clean all
yum repolist
yum update
1

As the content of rhnplugin.conf shows, that plugin is disabled. It shouldn't be, so reenable it by changing enabled = 0 to enabled = 1.

  • That's what I thought too. I checked another install that was working well. It also had enabled = 0. I tried changing it to 1 and did not see any difference. Am I missing something? – eisaacson Nov 11 '13 at 16:18
  • IIRC you can use either (classic) RHN or subscription manager... So no problem... – jirib Nov 12 '13 at 15:43
1
# subscription-manager register
Username: foo@example.com
Password: 
The system has been registered with ID: 653cb615-5f5e-4339-8d28-6dc67169ecb1 
# subscription-manager repos
This system has no repositories available through subscriptions.
# subscription-manager list
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        6.5 Beta
Arch:           x86_64
Status:         Not Subscribed
Status Details: Not covered by a valid subscription.
Starts:         
Ends: 
# subscription-manager attach --auto
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed
# subscription-manager repos
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   rhel-6-server-sam-source-rpms
Repo Name: Red Hat Subscription Asset Manager (for RHEL 6 Server) (Source RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/subscription-asset-manager/1/source/SRPMS
Enabled:   0

Repo ID:   rhel-ha-for-rhel-6-server-beta-debug-rpms
Repo Name: Red Hat Enterprise Linux High Availability (for RHEL 6 Server) Beta (Debug RPMs)
Repo URL:  https://cdn.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/highavailability/debug
Enabled:   0

Repo ID:   rhel-6-server-rhev-agent-beta-debug-rpms
Repo Name: Red Hat Enterprise Virtualization Agents for RHEL 6 Server Beta (Debug RPMs)
Repo URL:  https://cdn.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/rhev-agent/3/debug
Enabled:   0

Repo ID:   rhel-6-server-cf-tools-1-source-rpms
Repo Name: Red Hat CloudForms Tools for RHEL 6 (Source RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/cf-tools/1/source/SRPMS
Enabled:   0

Repo ID:   rhel-6-server-rpms
Repo Name: Red Hat Enterprise Linux 6 Server (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/os
Enabled:   1
...snip...
# yum repolist
Loaded plugins: product-id, security, subscription-manager, versionlock
This system is receiving updates from Red Hat Subscription Management.
rhel-6-server-cf-tools-1-rpms                                                                                                           | 2.8 kB     00:00     
rhel-6-server-cf-tools-1-rpms/primary_db                                                                                                |  18 kB     00:00     
rhel-6-server-rhev-agent-rpms                                                                                                           | 3.1 kB     00:00     
rhel-6-server-rhev-agent-rpms/primary_db                                                                                                |  18 kB     00:00     
rhel-6-server-rpms                                                                                                                      | 3.7 kB     00:00     
rhel-6-server-rpms/primary_db                                                                                                           |  23 MB     00:11     
rhel-ha-for-rhel-6-server-rpms                                                                                                          | 3.7 kB     00:00     
rhel-ha-for-rhel-6-server-rpms/primary_db                                                                                               | 203 kB     00:00     
rhel-lb-for-rhel-6-server-rpms                                                                                                          | 3.7 kB     00:00     
rhel-lb-for-rhel-6-server-rpms/primary_db                                                                                               |  14 kB     00:00     
rhel-rs-for-rhel-6-server-rpms                                                                                                          | 3.7 kB     00:00     
rhel-rs-for-rhel-6-server-rpms/primary_db                                                                                               | 223 kB     00:00     
repo id                                                  repo name                                                                                       status
epel                                                     Extra Packages for Enterprise Linux 6 -                                                          9,984
rhel-6-server-cf-tools-1-rpms                            Red Hat CloudForms Tools for RHEL 6 (RPMs)                                                          31
rhel-6-server-rhev-agent-rpms                            Red Hat Enterprise Virtualization Agents for RHEL 6 Server (RPMs)                                   32
rhel-6-server-rpms                                       Red Hat Enterprise Linux 6 Server (RPMs)                                                        11,114
rhel-ha-for-rhel-6-server-rpms                           Red Hat Enterprise Linux High Availability (for RHEL 6 Server) (RPMs)                              287
rhel-lb-for-rhel-6-server-rpms                           Red Hat Enterprise Linux Load Balancer (for RHEL 6 Server) (RPMs)                                   11
rhel-rs-for-rhel-6-server-rpms                           Red Hat Enterprise Linux Resilient Storage (for RHEL 6 Server) (RPMs)                              333
repolist: 40,228
  • thank you. what does it means if it registers successfully but no products show up when I run subscription-manager list? – eisaacson Nov 12 '13 at 16:22
  • no idea, i use RHN classic normally. but you pay subscription no? then make a call to support :) – jirib Nov 13 '13 at 7:43
0

I don't know much about why your configuration is hosed... We've suggested the usual steps of checking the repository lists and config files. But if this is a new server and you haven't simply reinstalled by this point, I'd suggest doing so now...

At various points in my career, I'd perform a CD/DVD media-based RHEL or CentOS installation, and would end up with a quirky setup that didn't feel right. Sometimes an HTTP install didn't quite work well. Although rare, I just reinstalled the system and moved on. I've definitely had bad media and corrupted online repos before. This may not be worth troubleshooting :)

  • It's a pretty new install but we've already done quite a bit of other work on it. Reinstalling is definitely an option that we're looking at but in my experience, sometimes you just go through all that hassle to find the same problem is still there. I'd rather just fix it. – eisaacson Nov 12 '13 at 16:17
  • 1
    You've done work, but haven't had any ability to upgrade or install new packages? – ewwhite Nov 12 '13 at 16:18
  • Somehow, we've been able to install something. This isn't the first I've done anything on it, just the first I've noticed this issue. – eisaacson Nov 12 '13 at 16:33
  • @eisaacson Oh, then it's likely the cert issue noted in another answer. The full technical details are behind a Red Hat paywall. Can you see them? – ewwhite Nov 12 '13 at 16:39
0

A quick search found Red Hat Solution #67936 which recommends contacting support to get it resolved.

It could be your entitlement certificate is corrupt.

  • verify the entitlement certificate with openssl x509 -in /etc/pki/entitlement/3019xxxxxxxxxxxxxxx.pem -text -noout
  • check /var/log/messages for warnings from rhsm-complianced
  • check the rhsm.log logfile for messages
  • Run yum update to verify whether or not repositories populate after initial update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.