-1

I have a corporate laptop that was provided to me by a client and I'm having some rather odd difficulties with it when I put the laptop on my home network. When I first brought the machine home it behaved like any other laptop. Once it was connected to the network it was assigned an IP address and I could remote into it just fine using the machine name.

Lately though, whenever I put this laptop on my network I am not able to ping or RDP into the machine as the host name doesn't properly resolve. Additionally I'm able to see the device and it's assigned IP address clearly in my router firmware.

This gets even more strange as now when I try to ping it's IP address listed in my router, I see that it's actually trying to ping my own machine (screenshot of this very odd event below).

Ping Screen Capture

This has actually driven me crazy to the point that I have actually replaced my router (it was behaving oddly in other ways), and I'm continuing to have these problems. The above ping capture is from the new router.

As far as network goes I am now currently using an NetGear R7000 Nighthawk and I haven't customized any of the networking settings in the router just yet (installed yesterday).

I would appreciate any advice possible and would be happy to provide further diagnostic information. Networking isn't my strong suit, so I'm not even sure where to begin unraveling this thing.

Update: The laptop has symanetec endpoint protection on it which I believe is what is preventing the rdp traffic from going through. I'm not sure why it's decided that my local network is evil, but I suppose I will have to follow up with their desktop support.

closed as off-topic by pQd, Iain, ceejayoz, Andrew B, MDMarra Nov 9 '13 at 18:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – pQd, Iain, ceejayoz, Andrew B, MDMarra
If this question can be reworded to fit the rules in the help center, please edit the question.

  • On second thoughts- this is quite "off-topic" because Server Fault is for IT Professionals, but the level of technical understanding in this question is more suited to Super User. Voting to migrate this question there (people there know what they are talking about, too!) – Austin ''Danger'' Powers Nov 9 '13 at 18:58
  • We'll if you guys are having problems with site activity maybe opening it up a little to give enthusiasts a chance to learn from professionals might help... – David Nov 10 '13 at 0:13
1
  1. Destination Host Unreachable means that the computer you are pinging FROM did not get an ARP reply from the computer you are pinging TO. In order for your computer to ping the other computer, your computer must learn the MAC address of the other computer. It does this by sending an ARP request. It is asking "What MAC address belongs to this ip address?" and when it gets no reply it informs you of that. So, it is not pinging itself. It is telling you "I, 192.168.1.3 cannot reach 192.168.1.4 because no device with the ip address 192.168.1.4 responded to my ARP request".

  2. In order for name resolution to work reliably you need to have some type of name resolution mechanism in place such that every computer can "register" with and query a common namespace. That is typically done with DNS. Seeing as this is a company laptop on a home network my suggestion would be to forgo setting up and configuring an internal DNS server but instead to just connect to this computer by ip address instead of the name.

  3. Not being able to ping the computer and not being able to connect to it via RDP are two very different things. There are a multitude of reasons why a computer may not respond to ping but is otherwise completely fine and ready to service incoming network traffic/connections. My suggestion would be to try connecting to it via RDP using the ip address it's been assigned and troubleshoot from there. People get hung up on why a computer doesn't respond to pings rather than focusing on the root issue, in your case why you can't RDP to the computer. Ping isn't going to tell you anything about whether or not you can connect to the computer via RDP. A successful ping may tell you that the computer is in fact connected and responding but a failed ping doesn't confirm the likewise.

  • Thank you Joe for your helpful answer. In this case I tried too ping the box to see if it could resolve the machine name to an IP. I attempted to RDP into it by IP from my routers config and couldn't reach it. – David Nov 10 '13 at 0:15
0

Nothing is wrong with your home network- and it is very much a classic home network (i.e. no DNS server).

Given that you have no DNS server on your LAN, why would you expect to be able to ping the laptop by hostname? Hostnames cannot resolve with no central record of them on your LAN (as you would have if you were running a Windows server which was handling both DHCP and DNS roles).

Here is a list of things to try:

You don't need to contact Symantec support. Just start by disabling Symantec Endpoint Protection by following these instructions:

http://www.symantec.com/connect/articles/sep-121-dos-commands

If the problem persists, then try the following:

  • double-check RDP is enabled on the target machine
  • try disabling the firewall on the target machine (you didn't say what OS?)
  • If it's Windows 7 (the same likely applies to Vista), you will need to enable ICMP in your firewall as an exception- otherwise you won't get a response to your pings even if they are reaching the target machine
  • in the absence of a DNS server (and if you are determined to do everything by hostname rather than IP address), you could set a static IP address on the target laptop, then add the static IP and hostname into your host file on your PC, so it can resolve to that hostname whenever you try to contact it.
  • Thanks for your response. I tried using the ip assigned by my router as seen in the routers config table. I am going to contact my clients support team and inquire about assistance fixing the issue. – David Nov 10 '13 at 0:17
  • If you try all the steps I mentioned you should be able to fix it. – Austin ''Danger'' Powers Nov 10 '13 at 3:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.