3

I am running CentOS 6.4 Kernel version 2.6.32-358.23.2.el6.x86_64 #1 SMP and have the following nfs info:

  • nfs-utils-lib-1.1.5-6.el6.x86_64
  • nfs4-acl-tools-0.3.3-6.el6.x86_64
  • nfs-utils-1.2.3-36.el6.x86_64

and am trying to mount an NFS volume with nfs3. I have the following line in my fstab:

172.16.11.87:/volume1/web /home/nas nfsver=3 rsize=8192,wsize=8192,timeo=14,intr(no_root_squach)

When I run nfsstat it still shows the client as nfs4

Server rpc stats:
calls      badcalls   badauth    badclnt    xdrcall
0          0          0          0          0       

Client rpc stats:
calls      retrans    authrefrsh
1988817    6          1988818 

Client nfs v4:

null         read         write        commit       open         open_conf    
0         0% 36943     1% 21606     1% 401       0% 392369   19% 375986   18% 
open_noat    open_dgrd    close        setattr      fsinfo       renew        
0         0% 0         0% 387945   19% 22904     1% 3         0% 2914      0% 
setclntid    confirm      lock         lockt        locku        access       
1         0% 1         0% 0         0% 0         0% 0         0% 97856     4% 
getattr      lookup       lookup_root  remove       rename       link         
613996   30% 29888     1% 1         0% 1248      0% 253       0% 414       0% 
symlink      create       pathconf     statfs       readlink     readdir      
26        0% 226       0% 2         0% 3         0% 0         0% 3825      0% 
server_caps  delegreturn  getacl       setacl       fs_locations rel_lkowner  
5         0% 0         0% 0         0% 0         0% 0         0% 0         0% 
exchange_id  create_ses   destroy_ses  sequence     get_lease_t  reclaim_comp 
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 
layoutget    layoutcommit layoutreturn getdevlist   getdevinfo   ds_write     
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 
ds_commit    
0         0% 
  • what OS on your host? – Danila Ladner Nov 11 '13 at 18:52
  • Sorry should have said that in my original post, its CentOS 6.4 – rahrahruby Nov 11 '13 at 18:54
  • also post kernel version and nfs client package version, might be helpful as well. – Danila Ladner Nov 11 '13 at 19:01
  • I have added the kernel and nfs version in my post above – rahrahruby Nov 11 '13 at 19:06
  • ok. let me see. – Danila Ladner Nov 11 '13 at 19:17
6

You have misspelled nfsvers=3 and no_root_squash.

  • 1
    Actually, the misspelling is a very likely cause of this error, though I'd expect some kind of error or warning to be indicated for the invalid options. – Falcon Momot Nov 11 '13 at 20:54
  • I got that from the CentOs site. Changing it has no positive effecting in fixing the problem. – rahrahruby Nov 11 '13 at 21:21
  • 1
    You have missed the final s off nfsvers in nfsvers=3 – ramruma Nov 11 '13 at 21:49
  • copied from Centos site, doesn't matter though, cause I have posted the real fix above. – rahrahruby Nov 11 '13 at 21:56
3

nfsvers is an option.

<server>:</remote/export> </local/directory> <nfs-type> <options> 0 0 

It seems that you missed the nsf-type. Changing nfsmount.conf may solve the problem in a system that will never work with nfs4. I have faced the same problem and it was solved like this in your fstab

172.16.11.87:/volume1/web /home/nas nfs nfsvers=3 0 0
2

So that people can get a real answer to the problem, this is how I solved it:

in the /etc/nfsmount.conf:

change Defaultvers=4 to Defaultvers=3

That's it, it now shows up as

nfsstat
Client rpc stats:
calls      retrans    authrefrsh
6          0          6       

Client nfs v3:

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.