I have had MySQL installed for about 2 months on Windows Server 2003 R2. On start up we get presented with an error that says "High Severity Error - root element missing" followed by another high severity error that displays "Log file path must be defined before calling the WriteToLog method".

Any help with this would be appreciated!


This might be a problem with MySQL notifier config file. As described here, there is something wrong with your config file. You just have to remove it (or rename it to something else) and launch the MySQL notifier again - config file will be recreated automatically.

In my case, the config file was in the C:\Users\YourUsername\AppData\Roaming\Oracle\MySQL Notifier\settings.config path. Removing it solved the problem.

  • worked for me ty :) – Kushan Mar 15 '17 at 14:27

I, too, ran across this problem on my local install of MySQL Notifier, and neither deleting settings.config, nor reinstalling had any effect. Further investigation lead me to a file in the same folder with the name connections.xml that only contained a single space character. Deleting that file and restarting the notifier did the trick, though, so if (like me) deleting settings.config doesn't correct the problem, look for connections.xml, and inspect that file for possible problems, deleting when necessary.

  • 2
    I had the same problem and deleting these two files was the solution. thanks Dave. – Patrice Calvé Jul 24 '14 at 12:16
  • 1
    I had the same problem on Windows 8. Deleting connections.xml and settings.config fixed the problem. The both files can be found in C:\Users\User\AppData\.. – Mythul Feb 22 '15 at 10:10

The error appears due to a corrupted configuration file and the solution is to delete it as mentioned by Wojciech Frącz.

It can also appear due to dummy MySQL services (Leftovers from server installations not completely removed). Always make sure you're running the latest Notifier version available (that can be downloaded at mysql downloads page) first.

To solve the dummy MySQL services leftovers:

  1. Open a Run command window and type the following:


  2. Take note of any MySQL service that shouldn't be listed (attempted uninstall before).

  3. Open an Admin rights command window and type the command:

    sc delete "< Dummy_service_name_here >".

Restart Notifier and see if that corrected the problem.

If a similar error still appears afterwards, check if the stack trace shows the word CreateScheduledTask somewhere, that would mean something is wrong when Notifier tries to add a schedule task at startup to check for updates of any installed MySQL product.

A workaround is to open in notepad the settings.config file that was re-generated. Inside the file, look for a property called "AutoCheckForUpdates" and change the default value of "True" for "False" and run Notifier again, as noted in this post.


I had a defective setting.config and a superfluous connections.xml. When I renamed both, mysql restarted. I then set connections.xml back to its original name. This blocked starting again, so I removed it altogether and mysql is ok.


I solved deleting C:\Users\YourUsername\AppData\Roaming\Oracle\MySQL Notifier\settings.config It was full of zeros ("null" bytes).

Note that MySQL Notifier may be still running in background (but non working fine), so you should kill it befor then restart the app.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.