1

I'm an administrator on two different SBS 2011 servers. Both servers are running MS Exchange. They are on different physical location, different hardware, different domains both internally and externally. The only thing they have in common is the ISP.

Problem is, that I and some of my colleagues can't access the servers from our WiFi connection at home (ADSL). Our ISP's are different from each other, and no one of us have the same ISP as the servers. FUnny thing is, that we can connect to the servers if we use a 3G/UMTS/LTE connection, so I'm guessing that the problem is in our ISP's DNS routing. Another thing is that I sometimes can access the servers using my WiFi at home and some times I can't. Most often I can't.

Any ideas?

  • what connectioin you using ?.. For example I use DS-Lite and there is no way to connect to my server via IPv4, because of a 6to4 Tunnel. – suleiman May 19 '17 at 10:05
1

A domain server can run (silently in the woods?) and never help/effect anyone else on the 'nets. In order for a DNS server to be helpful it either needs to (a) be configured for your local resolution... that is provided to your computer as a reference machine whenever you're resolving any domain name or (b) be configured to answer for your domain.

I'd guess what's happening here is when you're connecting 3G or within your networks these servers are automatically being provided as resolvers (type a) so whatever you're putting in them is available to your users. However when you connect from anywhere else, you're using the DNS servers of your ISP or some other public system (like googleDNS or openDNS).

When you're looking for a type b service, your DNS servers have to be globally registered to be authoritative for the domain... that is if you review the whois for your server you should see those servers listed in the Name Servers section. To change this you need access to the domain registry account through whichever company it's registered. Of course there's probably already DNS servers listed with some configuration to provide mail routing and website delivery etc. You'll need the same settings in your DNS servers for things to continue to work correctly.

Notes

  • Because devices cache DNS information, if your working 3g case was a device that was on the network, disconnected/went to 3G and it still works... that isn't quite fully working (try with a 3G device that's never been within your network)
  • Your occasional wifi work case could also be on a device that has a cache of the DNS settings from the office, even though it's no longer there
  • The DNS servers could be acting in both modes, but configuration or firewall is preventing connection to the service from public networks. Since you say both machine are internal and external I assume they have two or more IPs each - one for public access one for private
  • The DNS servers could be acting in both modes, but configuration could be leading an external machine to try an invalid (internal) IP which isn't routable from outside the network.
  • nslookup and dig are invaluable tools to help you what's going on behind the scenes on your machine (there *nix commands, available in OSX and there are Windows versions)
  • Thanks for your very good and detalied explaination! My home router is using my private ISP's DNS servers. I've tried to flush my devices and computers DNS records, but without getting positive results. I've also tried to reset my router and this didn't help. This morning another of my colleauges experience the same problems. Could it be that the different ISP's DNS servers don't resolve the domain correctly? COuld the servers ISP's have a problem? – Carl Nov 15 '13 at 7:30
  • Try running dig example.com (in OSX/Linux, can also install for Windows) [where example.com is your domain] when at home and seeing what are listed for the name servers. If that looks right try dig server1.example.com (where server1 is one of the above two). If that works try traceroute server1.example.com and see if the routing works. – Rudu Nov 15 '13 at 15:27
0

You are definitely using different DNS Servers when connection through different carriers. In general every ISP is running their own DNS servers or they are using the DNS servers of partner companies. To get closer to the issues root I would suggest you should find the DNS servers with the wrong lookup data.

First thing you should check are the exact data delivered to the devices from the DNS servers by asking them explicit. Open a command window and try the following commands:

nslookup yourserver.yourdomain.com 8.8.8.8 (Google primary DNS server)
nslookup yourserver.yourdomain.com 156.154.70.25 (Comodo primary DNS server)
nslookup yourserver.yourdomain.com 208.67.222.123 (OpenDNS primary DNS server)

They should all return the same IP addresses for your A record inside your zone. If you get different results, you should check the configuration of your DNS zone (focus on the TTL, maybe your TTL is far too high and therefor changes in your zone are being replicated very slow)

If they return all the same result, you can start finding out the faulty DNS servers by checking if you and your colleague are maybe using the same ISPs DNS server. In general you can get the IP addresses of the carriers by searching them on google. Use them with the nslookup tool and if they still return incorrect values you should contact the ISP to inform them about their faulty configuration.

0

I had this exact problem and it turned out that my SSL cert had expired, as apparently it auto renews every three months. It took 6 hours of tennis email with my host to establish this, after they constantly insisted it was my internet, and that they never changed anything - well clearly something did change!! If you get the same problem, try logging onto your host panel, looking at your hosting package, and pressing the 'auto-ssl' button to renew your certificate. It then takes a few hours to go global. If it doesn't work then google cpanel and auto-ssl for more info.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.