2

Getting this error: Fatal error: Class 'PDO' not found

Have these lines in php.ini:

extension=pdo.so
extension=pdo_sqlite.so
extension=sqlite.so
extension=pdo_mysql.so

This shows up in php.info()-- --enable-pdo=shared' '

Have access to whm but there is no "software" tab from which to access easyapatche? Any suggestions??

closed as off-topic by HopelessN00b Jan 13 '15 at 19:45

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

4

What you have posted is correct assuming that the extension_dir is correct. It sounds like that the PDO extension is not compiled on your server. PDO needs to be enabled in easyapache and it sounds like your reseller account does not have access to easyapache. Because of this you will need to get the server administrator to make the following changes in easyapache.

Goto WHM »Software »EasyApache (Apache Update)
Select "Previously Saved Config (** DEFAULT **)" and click "Start customizing based on profile"
On the "Apache Version" page click "Next"
On the "PHP Version" page click "Next"
On the "Short Options List" page click"Exhaustive Options List"
On the "Exhaustive Options List" ensure that PDO, PDO sqlite and PDO MySQL  are selected.
Then Click Build on the bottom of the page.

Once easyapache completes you should have PDO :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.