5

I have downloaded and installed PostgreSQL 9.3 (64 bit) on a developer machine running Windows 8.1 (64 bit). This developer machine requires use of a proxy server for accessing hosts external to the LAN.

The StackBuilder 3.1.1 Wizard / Installer pulls the proxy settings from IE, and they appear to be correct, but when clicking the "Next" button, I receive a "Stack Builder Error" dialog indicating:

Failed to open the application list:
http://www.postgresql.org/applications-v2.xml

Error: The URL specified could not be opened.

I have been able to successfully download the application list using IE and Chrome with the same proxy settings the installer initially pulled from IE.

Other things I have tried:

  • Pre-pending the proxy server hostname with the protocol 'http://'
  • Used the proxy server's IP address instead of the hostname
  • Removed the proxy settings entirely

In the first two cases, the installer responds almost immediately with the error message above. In the last, there is about a 5 second delay before it responds with the error message above.

A similar problem seems to be documented as a bug on the PostgreSQL bug tracker but there has been no response to the initial report.

Is anybody familiar with this problem, and if so, what work arounds have been found to be effective in using the Stack Builder installer?

  • Sounds like a problem with your proxy (though why it works for Chrome and IE I don't know - maybe the installer isn't really respecting your proxy settings?). Contact your local administrator to get it resolved, or if you are the local administrator check the logs on the proxy and fix it if necessary, or exempt this machine from the proxy policy until the installation is complete if it's the installer's fault...) – voretaq7 Nov 15 '13 at 7:47
6

My LAN server doesn't have internet access, I also find that StackBuilder from EDB doesn't respect proxy setting on Windows (am upgrading to 9.6.2), be it IE proxy setting or the proxy setting box in StackBuilder GUI.

But it turned out to indeed support proxy. Just not through the GUI.

Try launch stackbuilder.exe from commandline and it worked.

Before that, SET Environment Variables like you usually did on Linux for curl/wget.

 C:\> set HTTPS_PROXY=http://address:port
 C:\> set https_proxy=http://address:port
 C:\> path_to_stackbuilder\stackbuilder.exe

My guess is though the GUI screwed up, the underlying network library (should be libcurl in this case) somehow managed to pickup those parameter.

Maybe few people needs proxy support, but hope this workaround could help someone.

  • This was the only solution that worked in my case. Thanks! – Chethan S. Oct 12 '17 at 7:31
  • 1
    It seems to be necessary that commandline is started as administrator, because the settings seem to be ignored when StackBuilder gets elevetad separately. I also found that the upper-case setting was sufficient for me (using StackBuilder 4.1.0). – halfbit Nov 16 '18 at 13:48
  • The gui seems to only support HTTP and not HTTPS (due to libcurl). The newer version mentions this. – takje Feb 26 at 23:00
1

I'm not sure if the Stack Builder is honouring the system proxy settings ... and to make life more difficult, we have an authenticating proxy.

I got around the issue by using Fiddler

Run Fiddler, then on the menu Rules, enable Automatically Authenticate

Run the Stack Builder, and set its Proxy to localhost and port 8888. Do this for both HTTP and FTP (the list is retrieved using HTTP, but the packages come over FTP)

  • Any way around this when working in an environment where FTP is banned? Can I force the package downloads over HTTP/HTTPS? (P.S. I have the same issue above where it says it cannot hit the URL when it can from IE) – Gavin Burke Nov 7 '16 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.