2

I've recently started working with imaging and deployment. We want to use WDS with MDT to manage images, as we're currently just imaging each different model of computer with Acronis, and have ~10 different images. This strategy is really hard to maintain, and makes imaging a more complicated process then it needs to be.

Unfortunately, I don't have control over any of the network infrastructure in my organization (small department within much larger organization) so PXE-booting with WDS won't work, so we'll have to use discovery images.

Currently, when booting off the discovery image, I the message

WdsClient: There was a problem initializing WDS Mode.

After looking through the setupact and setuperr log files in the X:\Windows\Panther directory, the actual error lines are:

CallBack_WdsClient_DetectWdsMode: Failed to discover WDS Server, Error [11001].
CallBack_WdsClient_DetectWdsMode: No PXE boot information is present in registry.

Error [11001] only occurs when I use the FQDN (comp.corp.contoso.com). If I use the hostname (comp) or IPv4 address then Error [2] occurs.

I've verified that I can ping the server using hostname and IP address, and the server's firewall is currently disabled for testing. Additionally, I can confirm through the setupacct log that my machine is getting a valid DHCP address and the correct command line arguments are being processed.

Does anyone have any insight or recommendations on how to solve this?

1

If you are using MDT, then you don’t need to use a WDS Discover image. Just use the LiteTouch boot images from MDT (the same ones you imported into WDS). You can use a DVD or USB drive, and MDT will pull the install image and any applications, packages, and drivers across the network. You will lose the ability to multi-cast, however.

PXE uses a small built in network driver, however once you have booted into a boot or install image, you will need the network driver installed. When you generate the boot images in MDT, you can have it install network and storage drivers at the same time. If you add new drivers, you will need to regenerate the boot images to get them installed.

When you create the discover image from a command prompt, you can specify the server name or IP address (not sure about the wizard). This is detailed in the TechNet article ‘Creating Discover Images

Hope this helps

0

I am not sure what you mean by PXE-booting not being an option. Is this because the BIOS of your org's computers do not support PXE, and that's why your using a Discover image?

What you describe sounds like your Discover image is loading but it's not finding the WDS server on the network. Are you able to confirm your WDS server is working, by connecting a computer that has PXE boot enabled, in the BIOS, and booting the Install image?

Some things to check, based on past experience, are to confirm you have included the network drivers in the image. Also check DHCP options 66 and 67 on your DHCP server. I have the ip address of my WDS server in option 66 and boot\x86\wdsnbp.com in option 67, and the DHCP server is running on a separate server, from the WDS server. Also confirm you have only 1 nic enabled.

This document - http://technet.microsoft.com/en-gb/library/cc770495%28v=ws.10%29.aspx#BKMK_O2 - says you can specify the WDS server, in WinPEshl.ini, without initiating a PXE request.

  • PXE booting unfortunately isn't an option, as I have no access to the DHCP servers. Running ipconfig on the command line shows that I have network connectivity, so I would assume I don't need to add network drivers to the image. Does this seem correct? I'll definitely take a look at that document, thanks. – lonleyppl Nov 18 '13 at 13:43
0

Don't worry about WDS for now, if you have a basic network setup, you can use MDT. Use the MDT boot disc. WinOutreach is right, you can use a DVD or a USB if you like. Just worry about getting MDT up and running first. If PXE booting's out of the question, that don't even bother with WDS, you're just wasting time. Stick with just lean clean and mean MDT for now, use it's boot media.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.