1

The next installment in my saga of doom is here! I feel as if I'm being dragged into this bureaucratic oblivion a little more each day.

Today's question's context:

My boss ordered me to make a network share so that the accountant can still use the accounting program, while the program will be on his hard drive, since the program isn't accessible no more on the now dead, buried, and mourned server.

Using a luckily uncorrupted backup, he successfully started the program. Here's where I come in, trying to share it. I ran into a problem, namely that the user cannot connect to the share.

"Multiple connections to a server or shared resource by the same user, using more than one user name are not allowed. Disconnect all previous connections to the server or shared resource and try again", the error told me then.

I singled it down to the boss' machine being picky, as I cannot connect to the share either from my Ubuntu netbook. I also tried creating a local account on the boss' machine, and activated the Guest account.

Both the accountant's and the boss' machines run under WinXPx64.

Any insight, tip, hint, or explosives thingie would be dearly appreciated.

Edit: I did check the share's configuration when I first shared it. "Everyone" and a local user account have both read and write permission on the share. The other connection settings (within the share) are set to be as permissive as possible, to make sure that I have the least possible problems setting it up, as I'm supposed to do it as fast as I can.

Edit revisited: It might be interesting to note that both computers are on a boat domain, and that I can't take them off from the domain to the Workgroup, lest I will break other stuff that is already working. Also, the domain controller (the ONLY one) is dead, and shares are working on other drives on the network, ie: a coworker in the same office as I have shared something over the network successfully.

  • The second part of the title is refering to what the boss is making me do now, making it work as soon as possible, no matter what, as long as it doesn't cost alot. – Olivier Tremblay Aug 18 '09 at 13:51
3

"Multiple connections to a server or shared resource by the same user, using more than one user name are not allowed. Disconnect all previous connections to the server or shared resource and try again"

This error is fairly common, and although it's pretty self descriptive, is usually misunderstood.

You can not connect to a share with more than one credential. If you map your S: drive to \\ServerA\c$\blah using the credentials joe.bloggs, you can not then connect to \\ServerA\c$\another_blah with a different set of credentials (say: jane.doe).

Check for any existing connections from machineA to machineB. To check this, on the machine acting as a share/server, right click My Computer, Manage, Shared Folders, Sessions. Is there a session already from MachineA to MachineB? What's the User? Is it different from the credentials you're trying to pass for this new session?

  • I'll look into that. – Olivier Tremblay Aug 18 '09 at 14:20
  • Joyz! That solved it! That was one unclear message all right. – Olivier Tremblay Aug 18 '09 at 14:37
  • Glad it helped :) – Izzy Aug 18 '09 at 15:17
  • Interestingly, while Windows is "smart" in that you can't connect to \\ServerA as a different user, it is "dumb" in that you can connect to \\1.2.3.4 where 1.2.3.4 is ServerA's IP address. Also, if ServerA has any aliases, you can connect to them, as different users, too. – David Mackintosh Aug 19 '09 at 5:01
1

If you open the context menu of the folder which you want to share, you get an entry "Share...". In there, you can set the amount of concurrent accesses to the share. This value is probably 1. Try to increase it.

Beware: If several users try to run the application at the same time, data corruption might occur. So it might make more sense to make sure that only a single user is accessing it at any point in time. You can use a simple text file with the name and phone number of the currently active user, so the next one can ask him to get out.

  • Sadly, it is already set to "Maximum", and I verified in the Computer Managment MMC if there were any session opened prior to now by the accountant. None found. Good call, though, and +1 for that. – Olivier Tremblay Aug 18 '09 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.