I got a problem since a while with my XP client connected on a 2003 R2 Server Active Directory.

Sometime GPO doesn't load when a user log on. Some other time, It work.

I search many time on google to find a solution about that problem but I never found one.

I look for DNS but it doesn't seems to be the issue there.

Is anyone already encountered this problem before?

Thanks for you precious answer it's been several months I'm searching for a solution since this problem happen in a school environnement so this is really important that GPO apply correctly everytime!

EDIT : Problem still not solved, did what all of you said but doesn't help... I'll check it out on monday when I'll go back to work.

EDIT : I'm still searching for a solution on this, suggested solution up to now still not resolved the problem. Thanks however for those ;)

  • What indication is there that the policy isn't applying? May 7, 2009 at 0:14
  • Actualy, Student have very restricted access to the start menu, they got logoff and only the program they need to access. When GPO aren't applying, the full start menu show and they can access configuration what they obviously CAN'T want GPO are really applied May 7, 2009 at 1:39

4 Answers 4


It may be something to do with group policy refresh settings.

I'd try:

  1. Disable Turn off background refresh of Group Policy in Computer Configuration | Administrative Templates | System | Group Policy
  2. Enable Always wait for the network at comptuer startup and login in Computer Configuration | Administrative Templates | System | Logon

Particularly setting 2 above; it may be that the XP machines aren't getting the GPO setting until they do a background refresh. If it's a per-user setting rather than using loopback, and you're removing the profile on logoff, then this would definitely apply.

  • Waiting for network connection option was already enable, that was one of the first thing I tried. Concerning disabling GPO Background Refresh, I just enable this option, I'm waiting to reboot the lab because there's actually students working but I'll reboot my lab at the break and told you how it goes after ;) Usealy when I reboot the lab everything is fine, than after less than a day, probably when they refresh, they just go away. So I'll see how it goes and I'll hit you back to give you news about it ;) May 7, 2009 at 13:36
  • Hey it's actually looking very good right now, looks like it was crashing during the refresh. We'll see if will last but it looks like the solution to me! Thumbs up ;) May 8, 2009 at 15:26
  • Oops, doesn't work finally... Just saw student having full start menu just like I described above... May 8, 2009 at 19:23
  • Are you sure the students aren't doing something physical? Like unplugging the network cable while logging on?
    – Tubs
    May 19, 2009 at 9:32

Run rsop.msc, the Resultant Set of Policy snap-in, against the machine and the user that's having the problem. What does it tell you? (If it can't run, then that's a result itself--the GP processing is broken on that machine.)

  • Thanks! I'll check it out tomorrow when I'll be at work. I'll give you news about it ;) May 31, 2009 at 16:13

One thing I always use when troubleshooting GPO issues is the gpupdate/gpresult commands.

I'm not sure if you're familiar with these, but if not, simply open a command prompt on the client machine and type gpupdate to attempt to reload group policy from the domain controller. Also, gpresult will show you the policies being applied on the user and computer level since the last GPO update. You'll also see other bits and pieces such as domain

This information has really come in handy a number of times for me, so hopefully it will at least give you something to go on. I'd look at gpresult in particular in this instance.

  • I already worked with gpupdate/gpresult. Actually, when the policies doesn't apply correctly, I run gpupdate remotely on the client and then everything is ok but I just want to avoid that, weither it's funny to see the student face when a cmd windows flash in his face lol Anyway, I already checked with gpresult too, and when policies aren't loaded, they not appearing in gpresult as well and if I run gpupdate, then it appear in gpresult. Kind of weird... May 7, 2009 at 1:43


This note gives a few examples of troubleshooting GPOs. The only item I see that might apply is the "slow link" definition. Is it possible that the users are logging on with cached credentials or that the network isn't responding fast enough? Try modifying the Slow Link Detection.

  • I'll try it and hit you back after ;) Thx! May 31, 2009 at 22:26
  • I just setup this setting in my GPO, I'll see if it correct the problem. Thanks for the link by the way. Jun 1, 2009 at 15:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .