We have a small domain at the office running on a 32bit windows server 2003 (server1.domain.local). We have purchased a new server with windows 2008 R2 64bit (server2.domain.local) and plan to make it domain controller.

I followed one of many guides on the internet and executed all the necessary steps:

  1. On the old W2003 server: ADPREP32 /Forestprep, ADPREP32 /domainprep and ADPREP32 /domainprep /gpprep
  2. On the new server I ran DCPROMO and completed the task successfully (I only got the warning regarding DNS delegation)
  3. After completing DCPROMO and rebooting, I transferred FSMO roles to server2.domain.local, which appears to be working correctly:
    C:\Users\gseadmin>netdom query fsmo
    Schema master server2.domain.local
    Domain naming master server2.domain.local
    PDC server2.domain.local
    RID pool manager server2.domain.local
    Infrastructure master server2.domain.local
    The command completed successfully.

Now I tried to cut network access from server1.domain.local and whenever I try to access the "Active Directory Users and Computers" utility on server2 I get an error saying the domain cannot be found. And this is the result from netdom:

C:\Users\gseadmin>netdom query fsmo The specified domain either does not exist or could not be contacted.
The command failed to complete successfully.

I don't understand - shouldn't by now server2.domain.local be able to answer AD queries by itelf? Why does it keep looking for the old server?

  • 2
    Did you demote? where is the DNS server (on the server1 possibly?) – Cold T Nov 21 '13 at 13:22
  • I have not demoted server1 yet, I was hoping to be able to test the setup without finalizing the demotion (and possibly losing AD data, which would be a disaster!). – asg2012 Nov 21 '13 at 13:28
  • Did you install the DNS role on server2 and what is server2 pointing to for it's client dns settings? (i.e. in the network adapter settings) – HostBits Nov 21 '13 at 13:29
  • A dns server is now running on server2 and working correctly, all needed records appear to be there (_sites, _msdcs, etc) – asg2012 Nov 21 '13 at 13:29
  • What does dcdiag /s:server2 say? – Nathan C Nov 21 '13 at 14:01

This sounds like it is a DNS issue more than anything. You went through all the proper steps to add server2 as a DC and make it the holder of all FSMO roles. Considering that you also installed the DNS Role on Server2 and that all the Domain records appear to be there, this is probably an issue with your client DNS settings.

In the network adapter properties for Server2, do you have it pointing to server1 for DNS? If so, it should instead point to it's IP, and then it's loopback address. If you were going to keep server1 around then you would want that server's IP as the secondary DNS server instead of the loopback. Also make sure your workstations are pointing to Server2 for DNS instead of Server1.

Don't forget to DCpromo server1 out once you have a working environment.

| improve this answer | |
  • What about this (guide for migrating 2003 to 2012)? In particular the part where the old server is removed from the global catalog..Could that help? – asg2012 Nov 21 '13 at 13:59
  • Did you check your client DNS settings yet? What happens when you put server1 back online? What's the output of dcdiag /s:server2? – HostBits Nov 21 '13 at 14:09
  • I have narrowed the problem to the NETLOGON and SYSVOL shares not being correctly created. The NTFRS keeps failing when attempting to copy the data, but the service is running on both server1/server2 and dns resolution (ping test) works fine also – asg2012 Nov 21 '13 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.