1

I am having trouble in getting IIS to access a share on a NAS not in domain. I have tried all the usual IIS workarounds I know with no luck, I'm hoping someone here will point me in the right direction.

I have a Windows 2003 SP2 64bit Server, non domain joined and a NAS which exports a CIFS share. I can mount this CIFS share correctly as a mapped drive with the provided credentials. However I need IIS to access this share and serve content from it. I'm using UNC paths always.

Here's the steps I tried:

  1. First off I created a local user account, added this account to the IIS_WPG group and enabled access delegation in the Local Security Policies.
  2. Then I set up the application pool for my site to use this new Loal user account.
  3. I even tried to edit the IIS metabase to give preference to NTLM authentication.
  4. I then tried to create another local user account with the same name of the one with access to the NAS and with the same password and tried to use it for the app pool identity.
  5. I tried to set up the site directly with the document root on the NAS with the "Connect As.." set as the REMOTENAS\user and P@ssw0rd.
  6. Tried also to set up a virtual directory with the same credentials above.

I keep getting a 401 error when trying to access content on the NAS.

Any ideas? :(

0

As a last ditch effort I've tried to change the default built-in user that W3SVC uses to a local user who should have access to the remote share, however I can't seem to get the W3SCV Service to start and I keep getting "Error 5 Access Denied". I followed this KB (Method 2) with no luck: http://support.microsoft.com/kb/325349

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.