I am using Proxmox. That should be clear by the title. I have developed a software program in vb.net that generates network configurations, and I just copy and paste to the correct files. I am using Bridged networking for both KVM and OpenVZ. I had a KVM VPS that was using an IP Address, we will say: XXX.XXX.XXX.XXX. I destroyed this VPS, and created a new one with the same IP that was OpenVZ. That has also been destroyed. Now, when I try to re-use that IP in OpenVZ or KVM,

I get the following error: IP's below are publically routable, as they should be. On other VPS's, I can ping the IP's, but on this vps, I can't even bring up the eth0 interface.

[root@g2s /]# service network restart
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  Usage: arping [-fqbDUAV] [-c count] [-w timeout] [-I device][-s source] destination
  -f : quit on first reply
  -q : be quiet
  -b : keep broadcasting, don't go unicast
  -D : duplicate address detection mode
  -U : Unsolicited ARP mode, update your neighbours
  -A : ARP answer mode, update your neighbours
  -V : print version and exit
  -c count : how many packets to send
  -w timeout : how long to wait for a reply
  -I device : which ethernet device to use (eth0)
  -s source : source ip address
  destination : ask for what ip address
Error, some other host already uses address XXX.XXX.XXX.XXX.

How can I go about fixing this issue? It is used on no other Virtual servers, I have the same problem with a second IP as well.

I have tried both Debian OS, and CentOS.

CentOS /etc/sysconfig/network-scripts/ifcfg-eth0:




I have also tried flushing the ARP Cache on the Node. Any ideas? I am a bit new to proxmox.

Edit: It works when using KVM, but not OpenVZ.

  • 1
    You might want to make your obfuscations more clear. The address you indicate is a publicly-routable IP. If you're using a private IP, it would be 192.168.x.x. – Magellan Nov 22 '13 at 19:03
  • I know it is publicly routable, it is supposed to be. Like I said, I am using bridge networking...This configuration works on every other server that shares the same IP Block. – Justin E Nov 22 '13 at 19:12
  • Thank you. The phrasing of your question was very strange though. And if it is publicly-routable, you should just replace the numbers with 'x' characters to avoid confusion. Especially since you don't appear to be using any other IPs in your question. – Magellan Nov 22 '13 at 19:19
  • @Magellan thanks for the tips. Do you have any idea what would be causing this? – Justin E Nov 22 '13 at 19:22
  • OVH probably has MAC address security on your switch port, preventing you from changing the MAC address associated with an IP (as happens when you destroy and recreate a virtual machine). You should contact them for assistance in this case. – Michael Hampton Nov 25 '13 at 20:25

(I assume you use RHEL6)

1) I'd try this : PREFIX versus NETMASK

2) If it doesn't work, I would try to get a clue with /etc/init.d/network stop;sh -x /etc/init.d/network start (be sure to use vitrual kvm while doing so; not standard ssh connection)

3) I'd start over with blank network configuration : The fact that it works with one virtualisation technology and not another makes me think the problem is not on ovh side.

  • As far as the node, it is using debian. I do keep getting emails from ovh regarding bad network configuration, but they don't have answers has to how to correctly setup. I will probably start over entirely and try that. Thanks – Justin E Nov 26 '13 at 11:13
  • You will get the bounty. But I have another answer. – Justin E Nov 26 '13 at 15:42
  • Good to know :) But it makes the question too localized :( – user130370 Nov 27 '13 at 8:02

OVH Does NOT Allow Bridge Mode with OpenVZ Containers. You can set it up successfully in KVM, but if you try in OpenVZ you will get an email stating it is misconfigured.

If you have a MAC Address assigned to an IP Address in your Manager, you will be unable to use it with an OpenVZ Container. So basically, no MAC Assigned, and configure it for routed mode. The reason I had trouble was because I had a MAC Address assigned, and was unable to setup routed mode, and when setup in bridge mode, they black listed my IP several times. Only Assign MACs for Bridged KVM Networking with OVH.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.