1

I currently have two databases running in production. One a master and the other a slave. I use streaming replication. I'm looking into using pg_dump and sending the file over to amazon S3. I already know how to perform the logistics of all that. However, I can't seem to run pg_dump.

When I run this command:

pgdump -U django_login django_db -Fc > db.backup

I receive the following response:

No command 'pgdump' found, did you mean:
 Command 'pg_dump' from package 'postgresql-client-common' (main)

So I checked to see if I did have postgresql-client-common installed. To check, I ran:

~$ sudo apt-get install postgresql-client-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
postgresql-client-common is already the newest version.
postgresql-client-common set to manually installed.

So I know I have it installed. I ran the command again:

pgdump -U django_login django_db -Fc > db.backup

and received the same response. I'm currently running postgresql 9.1. What kind I do to fix this problem?

1
  • 5
    This question appears to be off-topic because the OP can't read the information provided.
    – user9517
    Commented Nov 22, 2013 at 22:11

1 Answer 1

6

No command 'pgdump' found, did you mean: Command 'pg_dump' from package 'postgresql-client-common' (main)

The command is pg_dump, not pgdump.

It's okay, it's Friday, and you probably need a beer or three. :)

1
  • wow! I didn't even notice! ahaha yeah just had a beer ahaha thanks a lot man!
    – deadlock
    Commented Nov 22, 2013 at 22:05

Not the answer you're looking for? Browse other questions tagged .