0

I use Ubuntu 12.04, postgresql 9,1 postgis 1.5. I want to change database location. I use instruction http://www.whiteboardcoder.com/2012/04/change-postgres-datadirectory-folder.html The only difference is that I do not use postgres account for changing file /etc/postgresql/9.1/main/postgresql.conf

When I resatrt postgresql i have error:

Error: pid file is invalid

This error exists in the bug tracker https://tickets.opscode.com/browse/COOK-3618

How can I change the database location?

  • Have you tried "manually kill the stale server process" like suggested in the 2nd link you gave? – user130370 Nov 23 '13 at 11:51
1

Use the appropriate tools - pg_createcluster in this case. Take a closer look at its --datadir= option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.