2

I'm using:

  • Jenkins 1.541.
  • Java JDK 7u45 (tried 64 and 32 bit versions).
  • XAMPP 1.8.2

I have downloaded the default MSI installation from http://mirrors.jenkins-ci.org/windows/latest, and I have installed it. Jenkins tries to run the first time, telling me Please wait while Jenkins is getting ready to work...

I wait but then the server, located at http://localhost:8080/ is down. The logs don't tell much:

jenkins.err.log

nov 26, 2013 5:58:20 PM org.eclipse.jetty.util.log.JavaUtilLog info
INFO: jetty-8.y.z-SNAPSHOT
nov 26, 2013 5:58:23 PM org.eclipse.jetty.util.log.JavaUtilLog info
INFO: Extract jar:file:/C:/Program%20Files%20(x86)/Jenkins/jenkins.war!/ to C:\Windows\Temp\jetty-0.0.0.0-8080-jenkins.war--any-\webapp
nov 26, 2013 5:58:45 PM org.eclipse.jetty.util.log.JavaUtilLog info
INFO: NO JSP Support for , did not find org.apache.jasper.servlet.JspServlet
nov 26, 2013 5:58:46 PM org.eclipse.jetty.util.log.JavaUtilLog info
INFO: Started SelectChannelConnector@0.0.0.0:8080
nov 26, 2013 5:58:46 PM winstone.Logger logInternal
INFO: Winstone Servlet Engine v2.0 running: controlPort=disabled
nov 26, 2013 5:58:46 PM jenkins.InitReactorRunner$1 onAttained
INFO: Started initialization
nov 26, 2013 5:58:46 PM jenkins.InitReactorRunner$1 onAttained
INFO: Listed all plugins
nov 26, 2013 5:58:47 PM jenkins.InitReactorRunner$1 onAttained
INFO: Prepared all plugins
nov 26, 2013 5:58:47 PM jenkins.InitReactorRunner$1 onAttained
INFO: Started all plugins
nov 26, 2013 5:58:47 PM jenkins.InitReactorRunner$1 onAttained
INFO: Augmented all extensions
nov 26, 2013 5:58:47 PM jenkins.InitReactorRunner$1 onAttained
INFO: Loaded all jobs
nov 26, 2013 5:58:52 PM org.jenkinsci.main.modules.sshd.SSHD start
INFO: Started SSHD at port 54677
nov 26, 2013 5:58:52 PM jenkins.InitReactorRunner$1 onAttained
INFO: Completed initialization
nov 26, 2013 5:58:52 PM hudson.TcpSlaveAgentListener <init>
INFO: JNLP slave agent listener started on TCP port 54678
nov 26, 2013 5:58:52 PM hudson.WebAppMain$3 run
INFO: Jenkins is fully up and running

After that, the server never initiates (at localhost:8080), and the Jenkins service is stopped.

I have also tried using XAMPP with Tomcat, trying both 32 and 64 bit Java JDK versions to no avail, since after starting Jenkins, Java crashes. I was trying to look for a crash log but can't find any.

These are the error events from the Event Viewer:

Faulting application name: java.exe, version: 7.0.250.17, time stamp: 0x51c4b3fd
Faulting module name: ntdll.dll, version: 6.1.7601.18247, time stamp: 0x521ea8e7
Exception code: 0xc0000374
Fault offset: 0x000ce753
Faulting process id: 0x15bc
Faulting application start time: 0x01ceeaee5b2a96ab
Faulting application path: C:\Program Files (x86)\Jenkins\jre\bin\java.exe
Faulting module path: C:\Windows\SysWOW64\ntdll.dll
Report Id: a49749d3-56e1-11e3-b08d-00155d011200

And

Child process [5564 - C:\Program Files (x86)\Jenkins\jre\bin\java -Xrs -Xmx256m -Dhudson.lifecycle=hudson.lifecycle.WindowsServiceLifecycle -jar "C:\Program Files (x86)\Jenkins\jenkins.war" --httpPort=8080] terminated with 255

Is there any other log I can provide to track the source problem?

  • I suspect this is a Java problem and not a Jenkins problem. Can you try the latest JRE (7u45)? – JasonAzze Nov 27 '13 at 1:41
  • Hi, I'm already using the last version. – Veehmot Nov 27 '13 at 12:59
  • Your event viewer says you're using u25. "Faulting application name: java.exe, version: 7.0.250.17" – JasonAzze Nov 27 '13 at 20:20
  • I suppose that's what Jenkins is using as the built in Java. I'll try with XAMPP and check the event logger. – Veehmot Nov 27 '13 at 20:29
  • I checked with the last version and it's the same error: Faulting application name: java.exe, version: 7.0.450.18, time stamp: 0x525404d0 – Veehmot Nov 27 '13 at 20:38
0

you can enable debug mode in java to get more details.... you may have to up the memory allocation available to java....

-Xmx256m

also, as jenkins creates a huge number of files, check to make sure you didnt run out of inodes

df -i

| improve this answer | |
  • OP is running Windows. So inodes aren't the problem. – JasonAzze Nov 27 '13 at 1:30
  • How can I enable debug mode for an specific Java application? – Veehmot Nov 27 '13 at 13:07
  • i was assuming there was a cli debug flag, but looks like its enabled via mgmt gui wiki.jenkins-ci.org/display/JENKINS/Logging – nandoP Nov 27 '13 at 20:17
  • Problem is I can't access the management GUI, since jenkins can't start. – Veehmot Nov 27 '13 at 20:22
  • compare a backup confix.xml file you have, to the one you are running. you can also fixup logging there, without need for gui. in fact, jenkins works great without any gui at all :D – nandoP Nov 27 '13 at 20:24
0

As @jasonazze figured out, this is an issue with this specific version.

https://issues.jenkins-ci.org/browse/JENKINS-20630

Downgrading fixes this bug.

| improve this answer | |
0

check the rights for c:\jenkins_node folder in windows

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.